Wgrpg

java

#10

You’re talking about Turris Puesco, right? I think the source was available on some git site. Does anybody have the link for that? I’d be interested in taking a crack at getting it running.


#11

I wish there were more games like this. Hard to find, but they’re always fun to play, even if they’re half-baked.


#12

@eidde yes I am talking about Turris Puesco. That game was sooo damn good! I wish we could all get a chance to play it again. Heres a copy of the master file: wgrpgv2-master copy.zip (480.7 KB)

Good Luck!


#13

Don’t sell the game short, it’s a nostalgic thing of beauty to me. Yeah it never got much passed a tech demo, but a lot of care went into accurately (or at least as accurately as can be expected) estimating the relations between height, weight, and metabolism, which nothing else has ever really come close to since. And I loved the idea behind the greed stat.


#14

how do i run the game?


#15

You have to host it on a local web server. I used XAMPP, and got the game to run by importing the SQL database into phpMyAdmin and connecting to it in XAMPP.

The problem, however, is that the SQL database included in UDaddy’s zip and the github for the game is incomplete. There are a lot of tables that are just outright missing, making the game unplayable, or, at the very least, missing content. For example as it stands, the database does not include any of the floor 3 content.

That being said, I’ve been doing work over the past few days to try to rebuild the database and get the game in a good position again. I’ve basically been playing the game over and over again, and fixing issues as they arrise, because I know that near all of those issue are with the database.

I don’t know if I’ll release the updated database though. I’d have to see what Crypic thinks about it. If he thinks it’s OK, I’ll probably release it (and maybe do some more work on it? idk).


#16

I didn’t get as far as you, but that’s pretty much the conclusion I came to as well. Looking at the repository, the last time the SQL folder was updated was before quests, classes, and the 3rd floor were added, and there’s probably a lot more little things in addition to those. Hopefully you’re able to release it, it would be a shame to do all of that work and not be able to show it off. Thanks, and good luck!


#17

@LurkerNo.2106 As long as you share the updated working link/ file to me Ill be happy! Please fix the game it would mean so much. Thx.


#18

Hey :smiley:
I am super interested in programming and stuff, but got no one till now teaching me… you seem quite skilled… Could you help learning the basics and always update me whenever there are news about wgrpg- i am really interested in this one :smiley:I dont know how to write personal messages here, i dont even know if its possible :joy:
Greetings Horbsch


#19

If you are looking for programming help or advice I would suggest you make a post in the programming sub category unless you have specific questions on this game.

https://forum.weightgaming.com/c/project-help/programming


#20

Are we able to ask questions about the game here?
If so I would like to know how you increase your character’s stomach capacity.


#21

by being lucky with the mystery potions. I dont think there is a way to stretch it with eating more food than the maximum capacity. but if you are lucky, it can get really big… once i was beyond 10lbs


#22

This is Cryptic on a different account. I suppose you have no way of knowing if that’s true or not, so you’ll just have to trust me for now.

I unfortunately did not create an up-to-date MySQL dump of my game’s database, so the one on my github repository is the latest. I had to reinstall WAMP, and I did not create a new dump or even backup my database, so all of that database stuff is lost.

I do, however have the latest files locally, so if I did any coding work prior to the latest release of the repository, at least that is preserved.

The last thing I got working was the party system, and if you enter a floor after the beginning tutorial event, the tutorial fairy gets thrown into your party and will randomly feed enemies or allies. There’s no UI for adding/removing party members though, that was what I was gonna do next before I ran into IRL roadblocks.

If you want to release a working version of the game, feel free. Ideally I’d want it hosted somewhere too so people who don’t know how to setup a local webserver can play too. Someone else would have to do it though; I can’t be arsed to spend any of my money on hosting a hobby project which is why the game is offline in the first place.


#23

Thanks alot, I’ll try it out later.


#24

Hi, I’ve also been trying to play the game locally and am new to php and have hit a bit of a snag. Whenever I select an option that prompts an action, this error appears: Array to string conversion in C:\xampp\htdocs\game\DialogConditionFactory.php on line 183

Undefined property: RPGCharacter::$Array in C:\xampp\htdocs\game\DialogConditionFactory.php on line 183

Uncaught Error: Function name must be a string in C:\xampp\htdocs\game\DialogConditionFactory.php:183 Stack trace: #0 C:\xampp\htdocs\game\command.php(40): DialogConditionFactory::evaluateAction(‘giveItem~11’) #1 {main} thrown in C:\xampp\htdocs\game\DialogConditionFactory.php on line 183

I’m not sure how an array is passed in because the the line in question only calls upon elements from the exploded strAction.

Heres the line in question: $_SESSION[$strSession]->$function[0]($function[1], (isset($function[2]) ? $function[2] : null), (isset($function[3]) ? $function[3] : null), (isset($function[4]) ? $function[4] : null), (isset($function[5]) ? $function[5] : null));

If you have any insight into how I can fix this I would greatly appreciate it.


#25

I believe this is because I coded the game in an earlier version of php. Some things have changed in the latest version (for example, you can’t have class constructors with the same name as the class which ALL of my classes use, what a pain!) and I imagine this is a side effect of that.

Set $function1 = $function[0]; beforehand and then try $_SESSION[$strSession]->$function1( … on line 183. Something like that will likely fix it.

It seems that you’re pretty close to getting the game up and running too, so well done!


#26

Thanks so much that did the trick! I have it running mostly well with the limited database, just with a bunch cut out.


#27

Interesting. I essentially came to the same conclusion about why the issue existed (You’d think PHP would keep old syntax working for legacy sites, but w/e); however, I had a different solution. I just put brackets around the first function[0], so it became:

$_SESSION[$strSession]->{$function[0]}($function[1], (isset($function[2]) ? $function[2] : null), (isset($function[3]) ? $function[3] : null), (isset($function[4]) ? $function[4] : null), (isset($function[5]) ? $function[5] : null));

Note that I probably know just as much PHP as the other guy (though I do have experience in other languages), but that solution seemed to work as well.


#28

Can someone please ping me once there is a working solution for dummies :smiley: or at least some tutorial or such


#30

I second this. Hopefully someone gets it up and running soon