Godot error help

a while back I encountered this error


as you can guess, I never had this error before. but paid no mind after making it go away in the first game that got this. but after downloading other games from here on the same engine, it pops up again and again

I tried searching for a fix but all of them did not help. either being about making Godot run or new projects to run.

It’s pretty bad for me cause it’s soft-locking me from playing any recently made games on Godot and I don’t know what else to do.

I am not a game dev, never had to download Godot before this. from what I learned is a renderer thing with Godot 4. Most if not all fixes I saw were about putting the game to either forward+ or gl_compatibility

so I’m making this thread for either help and see if others are suffering the same. and as a way of finding ways to fix this


The root of the issue is your video drivers do not support Vulkan. Vulkan what is called a graphics API (like DirectX or OpenGL) and is the successor to OpenGL. The reason you are seeing this now is Godot3 used to use just OpenGL but Godot4 switched to using Vulkan for handling its graphics.

Any games made on the Godot engine you where able to play where likely 3 but any new ones will more than likely be on 4. There is a known issue of godot not falling back to openGL though but that was supposed to be fixed back in 4.1 but some people do still encounter it in 4.2

There are a few options you can do to try to fix it

  1. Make sure your graphic drivers are up to date, and if they are not try to update them
  2. Run the game with the --rendering-driver opengl3 flag to force Godot to use the old opengl3 drivers
  3. If you are running and older GPU or something like intel integrated graphics you may need to consider upgrading to a newer GPU.

In general though option 2 should work for you if you where able to play the games made on 3.0

(Quick Side Note: I think the --rendering-driver flag is an engine level flag but I can not say for sure. Its possible its actually an option only for the editor but its worth a shot)


How do the --rendering-driver opengl3 part? every single thing tells me to do that but is only for Godot itself

the third and last one worries me. I have an Intel Intel integrated HD graphics 4400. I’m not in the condition to just buy a new one just like that.
can you confirm that there is nothing that can fix this on Intel integrated HD graphics 4400 besides --rendering-driver opengl3? or if that will even work? so can I at least know for sure there is no fix for my machine besides getting something with Vulkan?

Ah, yep that would be the issue. No way Intel integrated graphics would be able to handle it. Intel integrated is usually not good for much more then just basic graphic workloads.

The way you would use the flag is you would open a console window in the directory the game exe is in then type game.exe --rendering-driver opengl3 and see if that might help.

The thing to keep in mind with godot is the editor is actually a godot game so there is a possibility that is an engine level flag and might apply to all games made with Godot.

1 Like

could you be more detailed? I’m very dumb about this stuff
I tried opening the console in the game folder (the console for me is called PowerShell I think) but every time I type anything the > becomes red and doesn’t work

Can you post a screenshot of your console window? If you dont want to post it in here you can DM it to me if you wish.

I’m not a programmer either but I learned of a pretty handy shortcut trick you can use too (apparently they’re called shortcut parameters), as far as I know it basically does the same thing as running the game through command prompt/PowerShell but is IMO easier than using the prompt and eliminates the need to use it if you want to play a game more than once.

Here's a step by step method (assuming you're using Windows 10):
  1. Create a shortcut of the game .exe.
  2. Right-click the shortcut and then click “Properties” in the context menu.
  3. In the “Target” field of the “Shortcut” tab (apologies if the actual names are off as my system language is Portuguese), simply add the --rendering-driver opengl3 at the end of the line.
    Once done, all you need to do is save, then run the game through the shortcut and it should run normally.

I’ve had the same issue as you for a couple games as I also have an Intel integrated card, although for the error messages told me of the fix so it wasn’t much more than an inconvenience. The shortcut parameter method has worked perfectly for every game with this issue I’ve played so it should hopefully work for you too.


thank you. this worked! :grinning: