I can get it to run in cmd but i cant seem to run it normally

I was able to use command prompt to run it in the more classical text version but i want the full java version to run, but it wont. when i run it, a new java process opens in task manager but nothing ever comes up


I’m sorry you’re having problems! But, welcome to WG.

If you are able to run GameF.jar from a command prompt, but not the GUI, what happens if you run the GUI from a command prompt? Try:

java -jar GameFX2.jar --debug

Does that produce any output on the console? What does it output?
Other useful infomation would be what OS are you using and which version of Java you have:

java -version

And also which version of the game you have downloaded. I’d like to understand what is going on so I can fix it.

when i run it i get this error
C:\Users\egvro\tmp\yaffaif-v039>java -jar GameFX2.jar --debug
Error: Could not find or load main class gamefx2.GameFX2
Caused by: java.lang.NoClassDefFoundError: javafx/application/Application

Okay, you have a version of Java without JavaFx. It’s either below 8.25 or likely much later where it became a separate loadable module. Go get the public release of Java 8 from java.com and try that.

i downloaded Java 8 and it still wont run. i used the command and i have Java version 15.0.1.

If you want to work with multiple versions of Java on Windows there is a good guide here.

A quick fix is to edit the start.bat (and/or startDebug.bat) file for Yaffaif. After the initial REM statements add these lines, changing the JAVA_HOME line to point to where ever your Java 8 JDK or JRE was installed:

set JAVA_HOME=C:\Dev\jdk1.8.0_25

Then run the edited batch file to start the game.