Quite a few Fat Fortnight games are hosted on Mega, but for some reason I haven’t been able to access the site. I’ve tried using different browsers, VPN and the Mega chrome extension, but have had no luck so far. Does anyone have any advice?

Some countries have on a black list because piracy, possibly some “anti-virus/firewall” programs block it too. I wouldn’t try using it from work, or a library. I have no problem with it from the .uk. Where are you (your DA says .uk too)?

Yep, I’m also in the UK. I’ll try turning off ublock, though I had the same problem on mobile, so I don’t think that’s it? Either way, thanks.

Maybe try setting your VPN to exit somewhere else geographically in case it’s your ISP that’s blocking it? I tend to go for Switzerland when I need … stuff … that I can’t reach from .uk.

Might be swinging wildly here or might not be but a shot in the dark here.

If you’re at an educational establishment using their network in your residence you may find the site blocked.

Otherwise all I can suggest making sure it’s not your pop up blocker causing the issue

Still no luck I’m afraid.