Release 0.36 2020-11-21 (Public) and 0.37 (Patreon Early Access)

The core of this release is a new engine component that allows one character
to “order” another to do something. It is intended to cover everything from
polite requests through to commands, dom/sub behaviour and potentially mind
control. This was rather more complex than I originally expected! At the moment
it is only exercised in Bluebelle’s job to take care of a soaked player; she
asks you to follow her. The farmhouse has been opened up and some rooms have
been added.

New stuff:

  • First set of rooms added to the farmhouse.
  • Added Bluebelle a worker at the farm.
  • If you arrive at the farm via the river route then Bluebelle will help you with your soaked clothing.

User interface stuff:

  • Option to obey an NPC added to that NPC on the person tab.
  • Doing as an NPC asks via other controls correctly interpreted as obeying.
  • When an NPC leaves your location you are told which way they went.

Other bits:

  • “Orders” component added to game engine.
  • Utility methods for talking and waiting built into the JobBase class.
  • Fixed plurality of panties, underpants, shorts, trousers.
  • Fixed a bug in DirtyArrayList that caused various subtle faults.
  • Fixed combat not recognising when one combatant is in a closed container and the other is not.
  • Fixed an error where the combat component could involve hidden characters on a critical miss.
  • Fixed the PastryBag clone/destroy error that would break Nug.
  • Fixed an error where enemies could get an extra hit in after you died.
  • Fixed the pain-au-chocolate having zero volume so you could eat them indefinitely.

Metrics:

  • 79 different locations (and another 126 in the advent dream).
  • 25 NPC characters.
  • 1435 Java classes (240k+ lines, 5.5Mbytes of source code).
  • 49 Story files (13k+ lines, 319kbytes).

Known bugs:

  • Bandits becoming unreasonably horny while you are caged by Nug.
  • Kobold guards have been caught eating their own “weapons” - it’s emergent behaviour (sort of)
  • Starting character sizes may be a little off after changes and need some further tuning

As usual, download from the usual place, and start a new game. Previous saves will not have the new content, and will likely fail to load.

If you would like to support the development you can do so on Patreon where there are a number of different rewards, including walk-throughs, early access, developer documentation, and more… .

Release v0.37 (Patreon Early Access) includes:

  • Kobold transformation now includes skin colour change.
  • Completed transformation of arm length, neck length and head size.
  • Potions indicate when you haven’t consumed the whole potion.
  • Rework of body to correctly scale minimum sizes.
  • Fixed eels incorrectly damaging tattoos and brands.
  • Many updates and bug fixes in transformation and body code.

Alternatively, if Patreon isn’t your thing I have a tip jar on ko-fi.

8 Likes

Have u thought about adding some sort of visual avatar to go with the text descriptions, or would that be too hard/ impossible to do?

1 Like

Nice work as usual, one of the main reasons why I visit this site.

1 Like

Yes, it’s something I’ve given a lot of thought to, and the internal body model is designed to make it possible by computing physical sizes of each body part. It’s going to be a fair chunk of work though, and I want to finish other engine components first as I anticipate that having to adjust the visuals when I change the underlying model will significantly slow down development. The first step would likely be a silhouette, much like Tainted Elysium had, but with fully coloured characters the end goal (every colour the game mentions already has an RGB value too) and backgrounds. Early releases actually had a blank space where the visuals were supposed to be eventually.

Now that’s something I’d LOVE to see. I hope this is becomes more than just a thought, but at this point I’m just happy to see you add more content to the game overall

I sometimes go back to tainted elysium just for the silouhette. Hold down the button of infinite encounters and watch it wobble.

3 Likes

When I try to run the start.bat file I get an error reading:
Error: Could not find or load main class gamefx2.Game.FX2
Caused by: java.lang.NoClassDefFoundError: javafx/application/Application

I couldn’t find anything on your site about troubleshooting this. Help would be greatly appreciated!

I’m not sure if you’ve cut-and-pasted this error message, but it should be looking for gamefx2.GameFX2 (no second ‘.’). Assuming that is a typo, double check you’ve followed the instructions on the download page, and unpacked the zip with an archiver like 7zip, rather than navigated into the zip using windows explorer (that never works properly). Check that you’ve the files shown in the screenshots on that page, and that the lib folder contains only three .jar files and nothing else. Don’t let your archiver unpack the .jar files into classes, this will break things.

If that doesn’t help there are more troubleshooting instructions linked from the download page. If there’s still trouble let me know what happened, particularly on the troubleshooting steps.

There are only two .Jar files in the lib file,
GameF and GameFx2Controls

Is there something I’m missing?

I have used 7zip to unpack properly btw

Sorry, my bad, yes there should be two, not three. There’s a third one that’s got Patreon stuff in it, but that’s not included in the standard download.

And what about the second .zip folder “GameFx2Controls.src”? Do I extract that too or do I not touch it?

Also to clarify, the GameFX2.jar doesn’t work, but the start.bat runs, but gives me the aforementioned error

What was tainted elysium again? sounds familiar…

Flash game with food and aliens that lay eggs in you. Which is also food, but temporary. Also, stuff like bursting, gender change and addiction are part of it, though most is toggleable.

Kinda abandoned last I heard, but still pretty nice because of the aforementioned silouette mechanic and having sound for eating and stuff.

That’s source code for open source components I built for the game (they build on other open source components), and I have to include them in the download. I’m honestly not expecting anyone to ever use them. You can ignore it, delete it, or even look inside if you wish.

I’ve pulled the download myself and I’m unable to reproduce the problem so far. Can you let me know which version of Java is being reported when you run start.bat please? I’m wondering if there’s a new security feature or something that’s causing trouble?

I’m running Java version 15.0.1

Ah, yes, that most likely won’t work due to the significant changes in Java 9 and above. I’m targeting the latest public/free Oracle version ie. Java 8 that people will get if they go to java.com. I think you should be able to run both versions side by side and the Java management will hand off to the correct version - though I haven’t tried it.

That did it.

I had to completely reinstall java because it wouldn’t just use the right version for some reason.

Would it be possible to add an easy method via debug mode to spawn items? I’ve gone through the game folders and found lists of items but it seems like you can only spawn certain potions at certain points possibly? For instance I can spawn a health potion on the kitchen floor but not any of the other potions in the folder that I tried.

Maybe just like a cheat code to add all types of x item category to the character or something along those lines.

There is a method to spawn items via the console, but they have to be ones that come from “factory classes”, there are other items where only one exists in the world, and those are created in the various .xml files that define the story (some are modified versions of the standard factory ones). So, for example, if you find this in an xml:

<clothing
    factory="clothing"
	facpart="bra"
	id="bra"
	colour="black"
	desc="bra trimmed with red lace"
/>

Then you can create the base version with the console command (the first part after the + is the factory, and then there’s a , and the facpart):

/+clothing,bra
+ created Food:console1

Then to modify it to match the one defined in the XML, you need to use the set operation on the id of the new item which is reported when you create it (here, it’s console1):

/=[console1].colour("black")
/=[console1].desc("bra trimmed with red lace")

Obviously you can go to town changing attributes of created items, but you can’t change its fundamental nature (ie. the class of the object): you can’t make a bra edible, or make food you can wear this way.

I’ve not encountered any issues creating items this way; it should work anywhere. Not all the potions that have implementations are available from the potion factory; mainly because they are still under test and not in game yet. The ones that should work are: potion,boobGrow, potion,bottomlessPit, potion,healingPotion, potion,koboldStrong, potion,lust, and potion,weightGain.

I hope that helps, sorry for the delay in getting back to you.

1 Like

I believe I was using an older version at the time. Updating to the latest made all the potions you listed spawnable.