Release 0.41 2021-04-15 and 0.41 (Patreon Early Access)

There was a release 0.40, but it had a bug, so here is 0.41! This is a roll-up
of the changes in both versions.

The focus in this sprint was working on the main quest, and the new “revenge
your parents” quest. Some good progress was made, but trying to get the front
desk working in the civilian guard building revealed a fundamental problem
with the way the locations and containers worked in the engine.

A new sub-location class that can be a part of a location with it’s own exits
solved this problem but required the complex NPC path finding and travel-to job
to be reworked. All the actions that deal with stance, containers, cages, and
locations also had to be re-factored, pulling all the shared work into a common
base class. This should also fix some of the strangeness with the Orc cage.

In order to speed things up a dialogue tester has been added to the debug
screen. I’ve wanted to add this functionality since I first saw it in the
Pornarium event creator. There’s a lot of dialogue to be added to the game
in the coming sprints and it was becoming painful to test. This should speed
that up significantly, as well as being a potentially useful tool for anyone
tinkering with the game.

Two new buttons allow you to change the font size of the game
making it larger or smaller (to a point). If you are running the game
maximised increasing the font size will make the text easier to read.

There are new custom stat bars too. These work around a bug in the JavaFX
progress bars that would not display small values, such as the player’s
“Fer” stat, and display bars that were slightly too small for other values.
They are also shaded now to reflect the nature of their values.

New stuff:

  • Quest revenge parents started (work-in-progress)
  • Added a new quest to track getting dry after falling in the river (complete) - suggested by @Lundar
  • Added civilian guard building ground floor
  • Added Sgt Rusty Steele
  • Actions added to stand from a chair and get out of a bed
  • Characters can get stuck in chairs and on beds
  • While sat in a chair you can reach things on an adjacent table without standing up

User interface stuff:

  • Font size adjustment buttons added
  • Custom stat bar control accurately displays small values, and can be shaded.
  • The contents of the story pane are saved when the game is saved and restored on load
  • The units selection is saved and restored in the same way.
  • Fixed display of quest part status to not cause unintentional evaluation and changes
  • Added dialogue testing pane in debug mode
  • Re-worked debug pane to allow ids to be entered and fix layout issues
  • Added “add to dialogue args” button to debug pane

Other bits:

  • Fixed game save problems
  • Fixed quest warning
  • New JavaFX property for the game’s colours
  • Changes to allow further UI customisation
  • Sub-location concept with it’s own exits added to the engine
  • NPC path finding and jobs re-worked to take account of sub-locations
  • Added common code to handle actions relating to stance and position in a location
  • Fixed out-of-sequence messages when waking up
  • Fixed Kerry recovery message errors
  • Fixed verb usage in Kerry’s chat
  • Fixed tool-tip generation incorrectly revealing the stepping stones in the river
  • Quests can now be set to be repeatable
  • Fixed a quest bug where pre-completed parts would be lost on quest start
  • Add work-in-progress flag to quests and quest parts
  • Allow quest parts to set other parts as “succeeded”
  • Fixed quest parts success and failure states not being “sticky” (so they can’t go from success to failure now)
  • Added debugEval flag to quest parts for debugging success and failure conditions
  • Add a “null” literal to the expression handler
  • Expression handler can now handle null in equals and comparison
  • Expression handler can correctly compare enum values


  • 104 different locations (and another 126 in the advent dream)
  • 26 NPC characters
  • 6 quests (2 unfinished)
  • 1545 Java classes (263k+ lines, 5.9Mbytes of source code)
  • 58 Story files (14k+ lines, 354kbytes)

Known bugs:

  • Bandits becoming unreasonably horny while you are caged by Nug.
  • Kobold guards have been caught eating their own “weapons” - it’s emergent behaviour (sort of)
  • Starting character sizes may be a little off after changes and need some further tuning

As usual, download from the usual place, and start a new game. Previous saves will not have the new content, and will likely fail to load.

If you would like to support the development you can do so on Patreon where there are a number of different rewards, including walk-throughs, early access, developer documentation, and more… .

Release v0.42 (Patreon Early Access) includes:

  • Added Lola to an expanded Beers
  • Added Civilian Guard Darthen
  • Wanted board added to Civilian Guard building
  • Added bandit reward to the wanted board
  • Added pre-flight checks for Java version and JavaFx presence with error window
  • Units selection defaults on startup if OS provides property

Alternatively, if Patreon isn’t your thing I have a tip jar on ko-fi


I can’t get enough of these, really love the work

1 Like

Great Work!
But i may have some problems. The Game starts as it should, but as soon as i am in the main menu it shows this message on the left:
[+FATAL: Could not initialise game.]
So i can’t even start a new game.

Any idea what i can do? I’ve already tried reinstalling java and the game itself, command prompts also didn’t help.

That’s a new one! My suspicion is either the game files were not unpacked correctly, or there’s a locale problem - possibly both. Do you run with a Japanese locale?

Can you run the game from the startDebug.bat script (or .sh if you are on a Unix-like platform) and take a look at the output in the terminal please? That should give some insight into where the load process is failing.

I figured out why debug won’t run.
when activating regular start up:
“Did not find debug properties file C:Users\Owner\gamefx2.props. Debug not enabled.”
you programmed it assuming people would place the game in C:\Users\Owner
That is why it doesn’t run debug.

No, I did not. The game is completely portable, it doesn’t matter where it is unpacked. That is where it looks for the debug override file, irrespective of where the game is. It hasn’t started in debug mode because:

  • The game wasn’t started with the --debug command line arg (which startDebug.bat provides), and
  • The debug properties file mentioned above does not exist.

no, startDebug.bat does not provide.
in 0.36 it did, but it doesn’t now.
I kept version 0.36 . it runs debug just fine. So you must have done something after 0.36 that causes the program to look for debug in a different location than where it looked in 0.36. could you please revert whatever it is you did to debug in the versions after 0.36?

ps. this fix would be worth making an update for asap.
I apologize if I come across as a douche.

Yeah so i looked into the startDebug.bat, however it seems as @ uwuowoonoawa mentioned that the game looks for files in another directory. Atleast that’s what i could read out of it:

java version "1.8.0_291"
Java™ SE Runtime Environment (build 1.8.0_291-b10)
Java HotSpot™ 64-Bit Server VM (build 25.291-b10, mixed mode)
Args: 1
Debug mode enabled.
Did not find debug properties file C:\Users\Username\gamefx2.props.
Warning: Cannot load icon /icons/flags/gb.png
+ Warning: Cannot load icon /icons/flags/gb.png
Warning: Cannot load icon /icons/flags/be.png
+ Warning: Cannot load icon /icons/flags/be.png
Warning: Cannot load icon /icons/flags/es.png
+ Warning: Cannot load icon /icons/flags/es.png
Warning: Cannot load icon /icons/flags/europeanunion.png
+ Warning: Cannot load icon /icons/flags/europeanunion.png
Warning: Cannot load icon /icons/flags/fr.png
+ Warning: Cannot load icon /icons/flags/fr.png
Warning: Cannot load icon /icons/flags/it.png
+ Warning: Cannot load icon /icons/flags/it.png
Warning: Cannot load icon /icons/flags/jp.png
+ Warning: Cannot load icon /icons/flags/jp.png
Warning: Cannot load icon /icons/flags/us.png
+ Warning: Cannot load icon /icons/flags/us.png
+ This is a text-based RPG. It includes scenes of a sexual nature.
+ By continuing to play you agree that you are over 18 years old, over the age of consent in your country, and not using a computer where such activity is prohibited.
+ This is an early version, the area you can explore is limited.
+ This game includes a library that is free software. For more information see the included source archive.

+ Engine Version V0.41
+ UI Version V0.41
+ Story Version null
+ Copyright (c) 2005-2021 David Cooke
+ The gorgeous Silk and Flags icon sets are from

FATAL: Could not initialise game.
+ FATAL: Could not initialise game.
Apr 25, 2021 11:09:56 AM com.sun.javafx.css.StyleManager loadStylesheetUnPrivileged
INFO: Could not find stylesheet: /gamefx2/gamefx2.css
Apr 25, 2021 11:09:56 AM com.sun.javafx.css.StyleManager loadStylesheetUnPrivileged
INFO: Could not find stylesheet: jar:file:/M:/HardDrive/GAMES/yaffaif-v041/GameFX2.jar!/gamefx2/controls/TextBoxAutoHist.css
Apr 25, 2021 11:09:56 AM javafx.scene.control.Control impl_processCSS
SEVERE: The -fx-skin property has not been defined in CSS for TextBoxAutoHist@27daa861[styleClass=textboxautohist] and createDefaultSkin() returned null.

1 Like

Thank you for backing me up :smile: !

1 Like

The startDebug.bat does send the --debug flag, it’s right here:
java -jar GameFX2.jar --debug

Your problem was that the batch file wasn’t finding the jar file. Something I have not been able to reproduce and a problem no one else has. I suggested using the property file as a work around, but you haven’t done that because you wouldn’t see the message:

Did not find debug properties file C:Users\Owner\gamefx2.props. Debug not enabled.

I suggest you actually, as suggested, create that file with the line:


Please don’t hypothesise about what has been changed, my deficiencies as a developer, or demand reversions. I have source control. The last time the way debug initialisation changed was in v0.25.

thanks for the help, i will try it out now.

From this log I can see the game isn’t pick up any of the resources packed in the .jar files. Not the icons, css, or game xml files.

Can you try:

  • Make sure your locale is set to a western one
  • Unpack the game again with 7zip (in case the archiver you used has done something odd).
  • Try running startDebug.bat again

It’s a completely different problem from @uwuowoonoawa 's one (which the previous reply is for).

Ok… So i did everything you mentioned. I checked my localication, unpacked it with 7zip and run the startDebug.bat again and, it still spits out the same error message. My last guess would be that it maybe has problems with my localisation that’s set to german? :thinking:

UPDATE: So it seems it had a problem with finding directories because i put the game in my external hard drive, moved it to my desktop. It now works flawlessly. Yet again, thanks for taking your time to help me, and keep up the good work :smile:

1 Like

Great work man, I still remember back when you could only explore the small village of like 4 people and not much of the mine. keep it up😀


@Ellis_Ackerman I’m glad you’ve got it working, but I’m curious why it didn’t work from your external drive. If you’ve a moment can you let me know what type of drive it is (HDD, SSD, USB memory stick)? Is it connected via USB or SATA? If you have the files still on that external drive can you check the ownership/permissions on the .jar files for me?

Internally the game is asking it’s own classloader to fetch those files out of the .jar. The classloader has already retrieved (some of) the classes, so I can’t imagine why it can’t find the other resources in there - and I’m not seeing any security exceptions that might suggest it’s a sandbox issue.

Sorry if i have typos (english is not my first language)

  • It’s a Western Digital Elements 2TB HDD
  • It is connected via USB 3.0
  • Permission/ownership is allowed by my system as admin and my PC

I believe it may be have been a problem because i put BitLocker on my HDD, and because of that i couldn’t fetch those files?