Release 0.49 2022-06-21 and 0.50 (Early Access)

Very well thought out and explained reasons. Thank you for taking the time.

I hope your health improves - it’s rough battling your own body not wanting to cooperate.

1 Like

I don’t think this counts as necro-posting quite yet. I did end up distrohopping for several reasons to an arch derivative. In good news, the AUR ‘java8-openjfx’ now has python2 specified though it’s no longer officially supported on distros. I got python2 installed and all was going well. Until gradle spat out the least helpful error I’ve ever seen BUILD FAILED in 0s ==> ERROR: A failure occurred in build(). Aborting… No indication of the specific location of the error like every other example that turned up in a search of stack overload. Just somewhere in build().

@mintedcondition If you happen to know what that means, I’d appreciate a hand again. I know just enough to get myself into trouble haha.

I got it to work. :slight_smile:

1 Like

For the sake of posterity (and future readers), how?

My apologies for the delay. I’m using Garuda KDE Dragonized, which is an arch derivative. It took quite a few tries and I’m not sure if some of the repeated steps are necessary so I’m going to lay out what happened as best as I can rememeber it.
I Git-Cloned ‘java8-openjfx’. And tried to build. I was missing a few dependencies that weren’t caught in the check. After installing all the dependencies I was missing, including python2 (which took quite a bit of time if anyone else needs to do this), I ran it again. Next stopping point was Gradle misbehaving. It didn’t give a specific error code so it took me a while to realize the version of gradle bundled into java8-openjfx was out of date. So I updated that via building from source and ran PKGBUILD again, only to get a checksum error. I went back to the repo page and asked about it, it was updated, rinse and repeat. Got a very generic build() error and was guided to set my system-wide java default to java8-openjfx (I was trying to only apply it while running YAFFIF but it wasn’t cooperating). Finally, it worked!
This was probably painful to read to anyone who knows what they’re doing more in arch, but I had just switched to it and hadn’t dedicated any time to studying the CLI in many years.

Hi, I’m using linux, and how the hell do i work this out? I’m using WINE and I don’t understand how to get the thing to run. Yes, I know cd (folder name) and wine (file name) in terminal
Screenshot 2023-05-14 10.04.13 PM

It’s a Java application so you don’t need WINE or any windows executable stuff. What you do need is to install the Oracle Java 8 runtime (JRE) for your Linux with the JavaFX components, then run GameFX2.jar or one of the scripts (which you may need to edit - ignore the .bat files too).

So, I think I have it already, right? That means I just have to run one of those things?

You need to set up the Java runtime first (should have had instructions where you got it - if I recall it’s basically unpack somewhere sensible where other optional binaries are installed /usr/local/bin?). Your linux may have a more recent version of Java which won’t run Yaffaif in which case you’ll need to edit and provide the location of your Java 8 runtime, then run that edited shell script.

Nice, just one final obstacle. I want to edit the file. I knew running it before opened it, but for some reason, it won’t open again. How the hell am I supposed to force it open? This SHOULD be the final step, and then I can stop asking.

Worth noting I got it running with the Liberica JRE 8 distribution, available here. Make sure to select the “Full JRE” or “Full JDK” to get their version of JavaFX.

Anyone using Linux can look at my adventures in compatibility earlier in this thread. It is highly dependent on which distro you’re using. I got an arch derivative called Garuda to work, specifically the Dragonized flavor, which is one of the options optimized for gaming.

If there are specific questions with error messages and such, please send me a PM. I am not an expert, but I’m willing to help to the best of my ability. I think it would be best to open a separate thread under YAFFAIF dedicated to Linux issues, so as not to clutter up this one further. I’ll get around to creating a new thread if anyone needs help.

^ @wtf and @ChlorideCull

Why Java/Flash instead of Twine?

1 Like

I’d say cause it grants more freedom, maybe. Not a programmer so I might be wrong.

1 Like

A few reasons:

  • At the time I worked for Sun, and Java was my day-job. It was what I was most familiar with, and it allowed me to develop my skills further. The first version (excluding the point-n-click version) with a user interface was built on the shiney new JavaFx.

  • Write once, run anywhere! I wouldn’t have to worry much about moving from Windows to Linux to Mac. At times development has been done on all those platforms, and Solaris.

  • When I started Applets and WebStart were still a thing, so the game could run in the browser (still sort of does if you’ve got IE and are perpared to edit the security settings).

  • Yaffaif has a complex model internally with the NPCs living their own lives away from the PC. It would be a nightmare to do in JavaScript (which is kinda broken given its rushed origin).

  • Java (like all compiled, type-safe languages) lends itself to finding errors both at compile time and unit testing. This is a huge boon to such a complex project and means that the bugs that do slip through are limited to specific story elements. You won’t see the kind of errors that can so easily slip through is Twine.

  • One of the central things I wanted to do was have both textual and GUI input, so it would have the richness of classic parser based IF, and the ease of use of a GUI. To do this at each of the player’s turns it creates a list of all the possible things the player can do. This list is used to both re-build the GUI each turn and add auto-complete to the text input. The number of possible actions is large (50…200+) so wouldn’t be suitable for the kind of choices that basic Twine links provide (building Yaffaif’s GUI using web components and JS was a non-starter). Twine (like Ren’Py) requires the author to identify a small set of the most important options rather than all the options.

Sadly, corporate shenanigans put paid to both applets and WebStart benefits.

For a guess, you aren’t that far off!


I keep into running some weird problems like I was trying to eat enough custard to turn into a Kobold but my character’s chest grew so large that they couldn’t move. Also a weird moment where after sleeping my character wakes up in a strange place where I have to go through a sewer grate and something involving a bird and stuff but I have no idea what to do with that. Also does the Kobold treasure do anything?

The potion gradually makes you shorter (like one of the Kobolds), but doesn’t change your weight, and it has to go somewhere!

That’s the Adventure/Colossal Caves dream, you can mess around in your dream, or just wait until you wake up.

Yes, it does. This may also be related to your first problem if you end the day with it nearby.

1 Like

Is there an vore feature planned somewehre? Just it’s good fitting with an belly capacity and wg gain feature in general, just asking. Also is there a new type of races of start that can be chosen up?

Do I have to be a furry to enjoy this game? I just played tramp and it was the best I’ve played, but I’m really only into weight gain and not furries or other tf. Should I just ignore this and wait for more tramp?

In it’s current state, you can avoid tf content thru player choice but it doesn’t have a Content Warning mode that explicitly tells you which choices lead to it like Insatiable Hearts. Development is focusing on the main story/worldbuilding so there’s not much weight gain content save for the descriptions for outgrowing clothes or things like that. It’s not furry-centric like noone’s FTAG, but it’s still scarce in WG content so in it’s current state I dunno if you’d like it

1 Like