Titled Dragon Game

Okay! After tinkering with it an extra day I have a build I’m not hugely unhappy with - it’s actually POSSIBLE to reach the ending. Anyone playing this game for funsies please go ahead and grab the ‘latest build’
If you’re a Gaiinjam judge please download the broken and not-fun one below :v - it’s not completable and therefore has no New Game+ but i think I qualify for the other two wildcards.

Titled Dragon Game is a fantasy rouguelike with a gameplay inspired by Betrayal At The House On The Hill. Your goal is to collect seven treasures while trying to keep a pursuing dragon well-fed enough to give up on attacking you.

FEATURE WISHLIST (Feel free to suggest more)

  • The ability to craft new homunculi (instead of being given a bunch at the start
  • Tainted versions of the player characters re-appearing in subsequent playthroughs
  • Different enemy dragons with different levels of appetite
  • Varieties of dragon attacks
  • A dungeon generator that generates a few less dead ends and doesn’t run out of rooms and repeat itself
  • Better pathfinding for the dragon
  • Specific abilities for character classes (Fashionista getting a bonus from worn items, alchemist being able to craft homunculi in any room, the randomly-generated class being innately lucky etc)
  • A use for that fairy I drew
  • A portrait for that sheep
  • More room-specific interactions

Just gave a couple playthroughs, and yeah those “literally impossible” scenarios that can spawn due to random chance (one way completely cut off by an immovable object, or an NPC can’t be moved because you don’t succeed their recruit check) hurts. Thankfully the game’s fast enough that it isn’t a total deal breaker.

I will say for those who keep to it, the absurd and vulgar comedy really hits well, ESPECIALLY in that end sequence, holy shit. And of course, just the sheer ambition of making something in RPG Maker that has barely any resemblance to how RPG Maker normally works or looks is chef’s kiss. Still gotta love that you keep doing that, Urg.

1 Like

So I got to the end and I got this error no matter what I tried. Anyone know why this happened?This text will be blurred

Hey, I think I fixed this one in the current build. It was to do with the pathfinding plugin still trying to control characters after the map changed X{

I got the same error at the end as well, with the latest build

I love this game, but I wish it had some more polish to it.
Also, do the movement points matter before the dragon shows up, because I got up to -22 at one time.

1 Like

They don’t really, I just wanted people to get used to them. But I didn’t make them reset X0

Ah, okay.

Also, beat the game earlier today, I’m sad the other dragons don’t show up in the dungeon, only the red one

1 Like

I see that this game is randomly generated. The only issue I have is sometimes a map cannot be completed and leaves you stranded in a spot impossible to move to the next room.
Cool concept. Didn’t really play it long enough to see any weight gain though, after 3 play throughs leaving me in a dead ends I got tired of trying.

Side note: Barb is best girl

1 Like

I got this error at the end of the game

Kudos for bringing such an ambitious idea to the table! The cat-and-mouse element of playing keepaway from a dragon and using your amassed retinue as distracting dragon snacks was inspired. Just such a shame about the execution. Commiserations!

Um found this glitch where if you beat the dragon before getting all 7 then your cam is stuck on the bolder because it close when you get seven and then you have to defeat the dragon to open it so it stays on the bolder waiting for it to move even though the dragon is already defeated also the second life screen is dark red I can’t see anything

I hope at least it gets some points for what it was trying to do, this is a truly interesting and unique idea and completely different to what everyone else did while still fitting the themes.

Found a glitch where Grundle just sort of wanders around the dungeon for eternity after she spawns and never allows me to interact with the game again - including pausing and saving.

It took her, like, 8 minutes to find me ( I just left the game running and did other junk while waiting to see what was gonna happen), thought that I was about to exit limbo via her eating me, then… she didn’t seem like she could interact with me and just left to wander again. I remain hopeful that one day my torment will end by the wrath dragon’s mercy.

Also, the game didn’t let me eat the slime girl no matter how many times I tried. Sadge.

First Round Scores

Jux Score

Category Total
Game Runs: 50.0
Use of Theme: 50.0
Art: 9.3
Writing: 7.5
Music & Sound: 6.45
Mechanics: 7.2
Game Concept 8.45
Use of Fetish 7.5
Judge Preference: 7.8
Wild Cards Attempted: 3.0
Admin Wild Card: 3.0
Patreon Wild Card: 3.0
Community Wild Card: 4.0
Total: 167.2

Alex Score

Category Total
Game Runs: 50.0
Use of Theme: 50.0
Art: 8.5
Writing: 8.0
Music & Sound: 7.5
Mechanics: 2.0
Game Concept 9.0
Use of Fetish 6.0
Judge Preference: 7.0
Wild Cards Attempted: 3.0
Admin Wild Card: 4.0
Patreon Wild Card: 2.0
Community Wild Card: 5.0
Total: 162.0

Roops Score

Category Total
Game Runs: 0.0
Use of Theme: 50.0
Art: 8.0
Writing: 7.0
Music & Sound: 7.0
Mechanics: 8.0
Game Concept 8.0
Use of Fetish 6.0
Judge Preference: 0.0
Wild Cards Attempted: 2.0
Admin Wild Card: 0.0
Patreon Wild Card: 4.0
Community Wild Card: 2.0
Total: 102.0

Final Score: 431.2

Is there a way to get a legendary treasure if if’s stuck behind lava in the lava baths with no other obvious paths to it? Otherwise I have the other six and the dragon defeated but I’m stuck in Limbo.

I think the map is somewhat randomly generated. That is though luck but I had found more than 7 treasures so just pick another one up?