Troubles with Joiplay

So, I’ve been trying to play some RPG-M games on android with Joiplay, but they always break.
There’s a problem with FOSSIL plugin (Error: FOSSIL needs to be the first plugin. If FOSSIL is not the first plugin, everything will break! (happens when I try to load in).

I tried turning off the FOSSIL plugin, and I even managed to load into the game, but when I entered the inventory or approached the enemy, the game broke (for example TypeError: this.requestBalloon is not a function).

I tried to change the type of a game to RPG-M XP, but now there’s another problem (check the screenshot, happens when I try to load in too).

Does anyone know what should I do?

Play on an actual computer?

I’m not familiar enough with the emulator to know much, but I know it has issues and sometimes is just not compatible with games. Have you made sure you’re running an up to date version of everything?

They also have a discord which might be a better place to deal with issues. The link is listed on their main page.

I downloaded the latest version today, so I don’t think it’s the version issue. I’ll try to ask on discord, thanks.

1 Like

Yeah FOSSIL breaks things. try renaming the FOSSILindex.html file to index.html then copy it into the www directory and overwrite the old index.html with it.


Thanks, I’ll try that!

1 Like