Burgomatic (BellyBelting and cocoacaesar's submission)

MOST RECENT VERSION:


Download:
https://mega.nz/file/glxyVBjC#YC6IPzkW2AjpotefnTGhdiWay1_An6g3PMUV2SvCBpI
Burgomatic is a puzzle game about setting up instructions for a series of machines and then watching them execute in hopes of building a specific burger.
Featuring the wonderful art of @BellyBelting, whom I can’t thank enough for collaborating with me on this.
Includes:

  • 6 different weight levels
  • Fully animated machinery
  • Dynamic burg technology
  • Music/SFX
  • Post-game free play mode
  • Autosaves
  • In-game tutorial page
  • Obnoxious dialogue
  • Demanding puzzle gameplay
  • No nudity (YouTube-friendly)

I encourage you all to check it out and leave your thoughts. It wasn’t easy to bring this to you, but I think it has come out really well. Let me know if you encounter any bugs, crashes, or other difficulties.
I’d also be happy to see what kinds of creative things you can come up with in the free play mode.

For the administration

I have been informed that it is discouraged for one user to participate in multiple entries during a single jam. However, this is not the only project that @BellyBelting is working on this year. I hope that this can be overlooked, given that he has worked quite hard to keep up with the demands of multiple groups, but in the event that you choose to disqualify all but one of the teams in which he is a member, I wish that this project be disqualified before any other, as I do not want anyone else’s disqualification to result directly from my posting this. Thank you.

41 Likes

I… Might recommend a separate illustrated guide for this one, honestly. It’s satisfying to see your final machine work, but the instructions themselves seem a little obtuse? Examples, Putting a single 1 action on every machine seems to be valid by the rules given, but won’t progress due to the “infinite loop” created. Further, I kept getting a “swappers can’t fire simultaneously” error when I had them all on a “wait” action, which doesn’t make a whole lot of sense to me.

The actual advancement of instructions is a little tough to read, too. I thought it was initially that there’s an eight-unit loop of time for everything, but there seems to be some kind of split between the droppers and swappers that isn’t well communicated?

1 Like

Strange, those things both sound like they shouldn’t be happening, and I can’t reproduce them on my copy of the game. Would you mind posting screenshots? It would help me troubleshoot.

That’s surprisingly complicated, i liked it.

1 Like

That’s a wee bit of an understatement, lol. Trying to get this machine to work feels like beating my head against a wall.

4 Likes

I tired messing around with this for a while but legitimately can’t figure out how to get the machine to work. I’m sorry but this game is waaaaay too complicated.

4 Likes

My game crashes whenever I attempt to start a new game or continue one. I can open the client and view the tutorial just fine.

That’s concerning. Do you have any information, like an error code?
I suspect that it might have to do with the creation of a save file, so it might be fixed if you create a file called “save.txt” containing only the number 0. Let me know if that doesn’t work.

I can’t seem to place ingredients anywhere, or have them appear. I tried selecting each one at least once. Or progress past the first tutorial.
Ingredients are selected, swappers (bottom) fire in 1200 - 0012 - 1200 … order (10 - 01 - 10 … also doesn’t seem to do it?)

Sorry, I’m not sure exactly what you’re describing. Do you have a screenshot of what you’re trying? Maybe I can help.

I actually found it pretty easy to understand, it was just a lot to take in all at once. Nice game!

1 Like

No error code, the game seems to load for a second and then the window closes. I tried making the save.txt file with 0, but nothing changed.

I think what the game is awesome, in the image that you share literally is example of how make the first machine, but I admit that to know to program help for someone can play.

That’s a shame; I’m having trouble narrowing this down. In my experience, there is normally no noticeable delay between clicking “new game” and having it start, since the loading is supposed to take place before the title screen. All I can suggest is to reinstall, or make sure that save.txt was in the same directory as Burgomatic.exe. Sorry I can’t get to the bottom of this.

I cannot for the life of me wrap my head around how to make the machines work. Can anyone provide some sort of tutorial of how to go about it, because it’s way too late for me to figure it out.

This remmber me the problem of me game that too use the library SDL 2.0, I think that can be the paraments when create the executable, in my case is because in the version of my game executable of released not had the paraments need for run correctly, but executable of debug yes had the paraments need for run correctly.

I believe I understand what you’re referring to, but in this case the error seems to be occurring some time after the executable has already launched successfully. The only difference between my debug and release builds should be that the release version has no console window. The problem must be something that my program is doing; I simply can’t find anything objectionable within the part of the code that the error would have to be in. Thanks for your insight, though.

A programming game like this seems daunting at first but it’s surprisingly fun! The limitation of only 8 operational inputs means that the space to design the solution is equally constrained, preventing it from spiralling out of your grasp.

The tutorial provided is fine but could be a little more user-friendly, perhaps with some example diagrams of the actions (it took me flicking back through the tutorial to realise the significance of action 2 - crucial for the final level!)

For anyone stuck on the final level, solution found here (slap the conditional button after the first patty goes down):

Enjoy your redundancy!

As a game, it felt satisfyingly complete as a nifty little puzzle game. Definitely put a grin on my face working out the solutions.

One niggle perhaps is the character’s arms. Why does she look like she’s tied up? :sweat_smile: Was there a force-feeding angle that got abandoned? It’d look a little more natural to have the arms resting on her lap.

On the whole a great entry! :+1:

2 Likes

That’s an impressively elegant solution. Good job!
For the record, this was never conceived as a force-feeding game. If I had to guess, I’d say the arms are back there to make more room for the gut, but you’d have to ask @BellyBelting .

They’re on the back because I wanted the WHOLE belly to be seen. Especially these little rolls

image

I did think that it might look like she’s tied up, I even considered just might as well tying her up to the chair, but she just has her arms crossed on her back because that’s the only pose I thought of that everything could be seen : )

2 Likes