Fatocracy - A Crusader Kings 2 (Base game now free to play) weight gain expansion mod

Yep, that is one of things I really need to work on and I plan to have all of the placeholder text gone at some point down the line, but it will be a fairly slow process.

Damn, the Hellenism thing is galaxy brain

So far my approach has just involved a lot of flat out cheating, lmao. You can press the “`/~” key to open up the console commands, and the wiki tells you how to do them. There’s also cheating mods, and just going into the game and/or save files.

I don’t like to go too far with it, like for example I don’t like to just flat out give myself money, new territories, new vassals, or automatically win wars, but I do like messing with my character’s traits and modifiers.

I usually give myself and my spouse immortality (no old age death, but can still die other ways) when I use the fantasy races from Luxuria Fantasia, just because flavor-wise I like it better that way. (especially when I’m playing the half-dragons, it just feels way more fitting in my head)

Plus I just flat out turned revolts in my territory off by modifying a certain file, since I found them annoying and felt like they happened too much and too easily. I could’ve just reduced them, but whatever.

2 Likes

I’ve been too busy with real life and such recently, plus a load of emotional baggage. Sorry for my recent lack of participation!

I tried playing the mod recently, but for some reason, it just continuously applies temporary obesity over and over. At the start of the game, and also whenever I pick certain decisions. So… yeah.

1 Like

Strange, maybe I forgot to add a trigger to a certain event, I’ll take a look at that. I think I know what the culprit is.

Edit: I can’t seem to replicate the issue, what decisions are causing this? Did you try reinstalling the mod (removing the fatocracy folder and .mod file out of the modding directory)

1 Like

Well, it wasn’t just the fact a decision was doing this, but it was also the fact that it happened literally at the start of the game. Like- as soon as I started, it talked about me drinking the immobility potion.

As for the decision that was making that happen, it had to do with a custom trait mod I had. Ruler Designer Unlocked. I’ll take a look into the issue myself- if RDU is causing the issues, I’ll let you know. Else… well, I dunno.

1 Like

Well, I did attempt without the mod, and it isn’t the source of the problem. I have no idea what’s happening, but the temporary immobility potion drinking event just activates every time I start up the game.

1 Like

Try without any mods on at all. If that doesn’t work, delete my mod from the folder and try putting in a new install of it. If all else fails maybe you could try a reinstall of the game, but if you do that remember to delete the CK2 folder in the Paradox Interactive folder before reinstalling (just remember to back up any save files you want to keep, or better yet, make a backup of the Paradox folder.)

Is anyone else having this problem?

I haven’t had the problem (using Old Gods, Sons of Abraham, LF and Tale of Nine Tails) but I did run into something that might be related. Checking out my bedroom options and checking my the food storage I was suddenly catapulted into an event where my ruler was drinking a temporary obesity potion and became…yeah you guessed it…temporarily obese. I’m not sure if there’s always a fat potion in the closet or if that’s a bug but maybe it’s a bug.

1 Like

Yeah, so, it seems that a lot of things seem to randomly throw you into the temporary obesity event randomly. Strange.

1 Like

Found the issue and fixed it. I have an event page that’s used to quickly add the effects of potions onto characters so I don’t have to type it out every time. The namespace was incorrect FATTENQUICKPOTION was what was written at the top, but the events all had the event id prefix “FATTENQUCKPOTION”. For now I’ve changed the namespace to the incorrect spelling, but I’ll be fixing that soon just so this doesn’t happen again or cause future issues.

Okay so I’m having a bit of a problem. Ever since I’ve gotten back home onto my normal computer, whenever I close a steam game my PC slows down significantly. I’ve determined it’s only steam after running other programs and games that don’t use steam and the problem didn’t occur (tested with a disc based install of Fallout 3 and an Origin based install of The Sims 4). When the computer is slowed after closing a steam game, my cpu and physical memory are still being used at the same rate as before I closed the game (in other words, my cpu and physical memory use don’t change). I’m at a loss of what to do. I’ve already tried reinstalling steam but that didn’t fix the issue. I’ve tried running games in offline mode but that also didn’t fix the issue either.

Its probably steam cloud sync that’s slowing ya down try turning that off i ve had that happen on another pc of mine .

1 Like

Yep that was it, thank you so much :slightly_smiling_face:.

1 Like

Yeap made an account just to tell you that xD kinda new here anyways thanks for the mod i ve enjoyed it so far.

3 Likes

I’m glad you did :slightly_smiling_face:, and I’m also glad you’ve been enjoying the mod.

EDIT: It seems I may have jumped the gun on it, it’s still happening. I did however find a consistent method to fix it, annoying as it is. I have to log out of steam, and close every single tab I have open, and then the speed returns to normal. Clearing the cache didn’t help either.

So in task manager what application is showing as using these resources?

1 Like

I am surprised by the amount of content added to this mod. Even the little details for events like pregnancy. Whenever I think I found all the details a new event pops up. Keep up the great work.

1 Like

So this mod has got me interested in playing CK2 and CK3, is there any chance that someone might want to later try making this mod for CK3? I came across a breast expansion mod on loverslab that has modded character models for much larger breast sizes so it shows that its possible to mad the character models to larger sizes, its just probably take some effort of the models to get them right and to minimize clipping. At that point if it can’t be solved just make it that the character models at very large sizes just end up nude as that would make some sense at those sizes.

This is a really interesting mod and it shows the amount of work that has gone into the design process for it to make sense and stay relatively accurate to the games world setting, good luck and keep up the great work

1 Like

There was a topic in another folder but the guy who was working on the CK3 adaptation vanished. I looked into some of the syntax changes and it looks like it could be done from an event / trait standpoint. The modeling gets tough though.

Wow how strange I guess just to be sure is to have taskmangment open when you replicate the issue and see if it is indeed steam or something interacting with it, the next things I would disable would be shader -pre-caching (enable it back if it doesnt fix the problem it adds a pretty decent performance boost to vulkan titles after all) , windows game bar and shadow play just as trouble shooting steps what are the specs of the sytem you are running?

1 Like