Forest & Shack (Quest WGRPG)

video-game
weight-gain
fat

#21

@11100100 At a certain point, too fat is too fat, and even wearing tight armor won’t help you fit. Fastened armor does give you about 6 inches of leeway, though.

Also, I found the spoiler command. Hover over and click to see the cheat code:

120

@Sweetsglutton I’ll look into it. Fixing several issues right now, so it may take me a bit to get to it.


#23

I figured why,when you use "nevermind third time gives you game over,here is a trick,instead of using nevermind use sell go in one direction and go back

I love the game,i hope would be finished,maybe a crafting system? Anyway,im here to help finding bugs as im good at


#24

Out of all the text games that have been posted, this one and Master of Flesh were my favorites! I’m really glad to see that you’re working on it again.

I’ve also run into a bug, I suspect it’s because I asked the fairy girl if I could help her without having the right equipment yet, judging by what I gleaned.

speak to Pervy Fairy Girl
The Fairy Girl looks you over.
‘Well, there’s a huge Bee Soldier guarding it. I may have been trying to steal some of its honey when I dropped it. Tehe.’
‘If… if you could defeat that Bee Soldier and bring me my Portal Stone, I would owe you a huuuuge favor. That’s, if you can, of course.’
Error running script: Error compiling expression ‘Long Sword.equipped=true and player.armor=true’: CompareElement: Operation ‘Equal’ is not defined for types ‘Object’ and ‘Boolean’

The sound of your breathing echoes dully between the trees.


#25

Also, once you get to a certain weight and have a certain amount of armor on, fighting gets a little buggy too.

You take 0 damage
Error running script: Error compiling expression ‘oponent.health - player.dmg2’: Unknown object or variable ‘oponent’
It’s a tall and fearsome bear with a big gut hanging down. It pants heavily and stands up on its hind legs to threaten you, before dropping down tiredly with a loud thump.
The {opponent:name} tries to use its speed advantage to get in the first hit, but you stumble out of the way.
What will you do?
fight run use potion

The sound of your heavy breathing echoes dully between the trees.

The previous wolf randomly hit me for “-196” damage and… now I’m walking around with 200 health out of 16. hmm!! Always happy to help playtest this game, I really love where you’re going with it.


#26

Yes, it seems after a certain weight, enemies appear with 0 HP and can’t seem to be hurt at all because of it. When they hurt you as a result of attacking, it’s always some very high, negative number, which gives you a lot of extra health.


#27

So, it’s about time I update on the latest bug-squashing progress.

These issues have been fixed:

  • monster attacks healing the player
  • monsters taking no damage, making unwinnable fights
  • pervy fairy girl not giving the quest

Reasons for those bugs:

  • typo in the “monster attacks first” section of the battle function, triggered by low player agility, triggered by wearing every piece of armor at “very tight” status.
  • see above.
  • typo. Should’ve be player.armored. Obsolete after armor update, so it’s been changed to a minimum atk and def stat.

I also improved the fairy girl’s dialogue to give the player a better idea of how to progress.

THE BAD NEWS:
When I was fixing the fairy girl, I realized that I never carried over the boss monster to the new combat system. Then I realized it’s too different to work with the pop-monster system and made a similar one for Boss monsters. Then I realized the honey-spout was incompatible with the eat_food function, so that needed a tailored copy. And various other such things popped up.

Until I fix these things, the game is kind of a bit broken. I’m quite busy with other things at the moment, but sometime this weekend I plan to upload the fixed version, (you guys can discover the next set of bugs), and I’ll get on the dismantling system for monster drops. Good? Good.

Edit: I’ve yet to check out the trade system bug. It’s on my list though.


#28

Wow!! So fast. I’d like to do this all in one post so as not to swamp your thread, but I think I’ll forget if I don’t post as it comes up…

Using potions in the middle of a fight doesn’t seem to work right now. Works outside of combat just fine.

fight run use potion
[Unrecognized command. Please type fight/f or run/r.]
What will you do?

This is by clicking on “potion > use” from the inventory menu in the middle of a fight. Take your time! Look forward to seeing the game evolve.


#29

Ah, yeah, I couldn’t get it to work directly from the inventory, that’s why I added the hyperlink. I could tidy it up though. Hide the inventory during combat, show the hyperlink only when the player has a potion. I’ve added it to my list.


#30

Oh! Interesting… I didn’t even notice, as it worked before the recent update. I’ll keep it in mind when I keep playing through. You’ve inspired me to see it I can’t get Twine 2 to work for an adventure game like yours. I’ll start making bug notes so I can just post all at once sometime instead of this thread dinging you over every little thing.


#31

It worked before the update? What? How? I spent ages trying to make the normal inventory panels accessible during combat, but I couldn’t figure it out.
If you’re sure it worked at one point, that would give me a reason to go back and try again, but that shouldn’t have been possible…


#32

fixed:

  • can now buy potions (there was a missing line in the trade functions)
  • created boss battle system
  • can now drink from the honey spout post food-update
  • rewards for boss battle fixed
  • player can now receive the first quest from pervy fairy girl
  • edits to first quest dialogue and functionality

not fixed:

  • couldn’t find this game-crashing trade bug people mentioned. Using nevermind repeatedly didn’t cause any issues for me.

other changes:

  • map textures updated
  • more map tiles added
  • inventory is hidden during battle
  • Use potion command only appears if you have potions
  • Added some brief post-quest dialogue with the pfg

Oh, it should be mentioned that I tested most of the changes, but not all of them. I’m consistently bad about that.
Now maybe I can work on the dismantling system.


#33

Seems like the last update might have broken something. Can’t seem to eat anything. (No rush. That was a big revision list, and stuff happens. XD)

Error running script: Error compiling expression 'food.eat_string</br>': SyntaxError: Unexpected token "/"; expected one of "-", <INTEGER>, <REAL>, <STRING_LITERAL>, "True", "False", <HEX_LITERAL>, <CHAR_LITERAL>, "null", <DATETIME>, <TIMESPAN>, "(", <IDENTIFIER>, "if", or "cast"Line: 1, Column: 25

#34

Oh good. Now how did I break that?
Do you remember what you were trying to eat?

Edit: never mind, I see it. It’s an obvious typo. I’ll fix it after lunch.


#35

Alright, that should fix that.

Another thing I feel I should note: if you have multiple copies of the same armor, the list won’t update like, Leather Corset XS (3) or whatever. It has to do with how Quest updates the names of wearable items, and I’m afraid to mess with it too much. But you do still have multiple copies.


#36

When I start outgrowing my armour, my max HP does go down, but how do I restore it? I tried taking off the armour and the max HP stays diminished. Is there code so that the max HP gets increased by removing the tighter armour?

Oh and another bug: If you see the main map as a 5x5 and look at it like an (x,y) graph, when the character is in area (2,2), the character is unable to move down to (2,1). Just a small thing, you can still get there by going around, just a minor bug.

This bug, as far as I’ve experienced, has been encountered when the player ‘thinks’ they are in Mel’s “sell” state, so you click the nevermind button after doing something else not pertaining with Mel while in the shack (unfastening/removing armour, taking a potion, checking yourself, etc.).
I believe this is because the command “nevermind” is synonymous with “quit” in Quest.
The solution could be to change the command for exiting out of this “trading” state, or reworking that whole process entirely.
An easy way to recreate the bug would be to do the following:

  1. Character creation
  2. north
  3. Trade With Mel.
  4. sell
  5. Look At Engraving Stone
  6. nevermind

When in the Hidden Path, you can put in “drink honey spout” before you start fighting the Bee Soldier. Doing this responds properly saying the Bee doesn’t like that and not-so-subtly hints that you need to kill the Bee Soldier first.
However, once you defeat the Bee Soldier and attempt to drink from the honey spout again, it is now empty, and responds as such.
My guess would be that the drink honey spout command checks to see first if there is a Bee Soldier currently in the area, and if false (there’s a dead one), it goes to another check to see if the command “drink Honey Spout” has been entered in whatsoever. If this is true (even if I got denied the honey from the Bee), then it denies you the honey and says the spout is empty.
As far as for a solution, I would think to create a different room that contains the spout, perhaps behind some vines or brambles that could appear when the Bee Soldier leaves the area. But there’s probably many ways to solve this.


#37
  • Fixed the map bug. Added the missing exit.
  • Fixed the trade bug. Changed the name of the quit command to something else so the game wouldn’t get confused. (Thanks for helping me find that.)
  • Fixed that special edible bug. A curly brace was in the wrong spot.

Those were all easy, but the armor one is… not. That stuff is all handled by Quest’s built-in multistate wearable functions, and I honestly think it’s a bug. I’m going to have to spend some time searching the forums for a fix for this one. In the meantime… Just do NOT remove and put on very tight armor repeatedly. It will keep subtracting a max health every time you do.


#38

So I found one bug that was there and still is here before the last update, basically after you send the fairy girl home and teleport to fairy city yourself and try and speak to her. The dialogue that appears states that it cannot find the variable or object “hey” and does not continue any further. This happens when either option is chosen. Just wanted to point that out, great game by the way.


#39

first one
When your armor snaps from you (wears off from weight) give the description and an error the error been
Error running script: Error evaluating expression ‘StringListItem(object.multistate_wearslots, object.multistate_status - 1)’: StringListItem: index -1 is out of range for this list (9 items, last index is 8)

Second one
After the armor snaped from you the hp points dont come back

Third one
If you try to wear an armor who you overweight it woulld instantly snap off but would give you an hp point been able to overhelm you hp


#40

Is there stuffing and bellies and the like in your game? I know the focus is on WG, but is there?


#41

I’m thinking about doing something like what fatty text adventure did at some point, where there’s a gap between eating the food and it becoming fat, but it’s very low on my priorities list.
I wouldn’t be against adding a stuffing event or something though. If anybody has a great scene written out that they want to share, PM it to me. I won’t necessarily include everything, and I might make some syntactical edits so it fits the setting better, but I could program it into an event without too much trouble.
Naturally, I’ll give credit to the author, and I won’t pointlessly throw it around in other places.

I’d like to make more events myself at some point, but writing takes time. :sweat_smile:
Also, just because there are things that other people love that I’m not so well-versed in, the idea of letting players contribute to the events is kind of cool. :blush:

Bug Squashing Status Update:

  • Think I found a fix for the armor bug, but it requires me messing with Quest’s functions a bit, which makes my head hurt, so I’m procrastinating.
  • Fixed the fairy dialogue bug: it was missing some quotes
  • Haven’t looked into the error that comes when you snap off the armor yet.