Forest & Shack (Quest WGRPG)

video-game
weight-gain
fat

#1

Forest & Shack

I will always keep the active link here ^

So here’s the WGRPG I was working on in Quest text adventure. I had this up on the old site, but my account got slashed so here it is again.

This game is about a person (age and gender of your choosing) who gets abducted by fairies and dumped in a forest. It’s a place where there’s no such thing as “getting full,” so your objective is to survive encounters with the local wildlife and eat to your heart’s content <3

It’s been too long. I have no idea where I left off on the updates. Well, this is version uhhh 1.4.2, probably.

Well, have at it!


Howdy! New member here!
#2

So I think this may be the site itself, but the Game Session keeps ending after like 3 or some actions…


#3

I played through the linked version for a while and it ran just fine. It’ll probably work if you wait a little and try again. Maybe refresh the page or something.

Also, as a side note, it will probably be a while until the next update. I’m reworking the armor system so there are multiple armor pieces each with various levels of how tight they are. Until I get it working, the armor system in my version of the game is basically broken, so I won’t be able to fix other bugs. ^.^;

The part that’s causing me headaches right now is that I want the player’s fat to be “compressed” if they manage to fasten tight armor, which might be just the push they need to crawl into tight spaces. When there are various levels of tightness, it becomes tedious to program. I’ll eventually get around to it. Then maybe I’ll finish fleshing out the stats system.


#4

This game was one of my favourites! I’m glad you’re back and working on it still.


#5

This would probably be the most frequently asked questions, so answer this for me

How big will they become?


#6

Wasn’t there a “cheat” code that would give you stuff? What was it again?


#7

@RadicalSquidward I’m happy to hear it. :slight_smile:

@NoNoYes Undecided. I’d like to leave the gameplay open to several different play styles, including the options to not gain weight (and still have a fun adventure game), to gain while adventuring, and even to settle down with a fairy and be pampered. Those things are still a ways off though.

@Fpiggit It’s the numerical representation of “thin to fat”. Three numbers, no spaces.


Unclaimed List
#8

Hey, good news. I figured out the armor thing. These things always seem to work out after I complain about them.

Anyway, I had to tweak the trade system so you could get your hands on the new armor pieces, and I figured I’d just overhaul the trade system while I was at it. So, that should be done in another day or two. Not sure if I’ll release the new update then or wait until I’ve tweaked the way dead stuff works first. (I want to let the player separate a dead creature into sellable bones and fur and edible meat (of random amounts). Because that sounded cool. I’ll probs add a new monster while I’m at it.)

Well, just wanted to let you guys know where I’m at and how things are progressing.

Ah, just fyi, those “new armor pieces” consist of six sets of five armor pieces that can be mixed and matched freely. That’s thirty armor pieces. Each new future set will also have thirty pieces. The reason this took so long is because I coded them all in a way that making new sets won’t be a nightmare.


#9

I’m stuck on the selling system. The buying system has been done for 2 days. I’ve tried everything I could think of to make it work, but it’s stubborn. All I’m trying to do is let the player sell things in bulk by typing in the number of identical items to sell. Why is that causing problems… and I think I may have figured it out as I’m typing this. Crap. I hope that’s what it was.


#10

It wasn’t what I thought it was, but I somehow managed to fix it anyway.
Notes for future programmers running into the same issue:

  • Functions with get input scripts don’t deal well with returning values. So work around that somehow.
  • If your function has an Ask script in it, don’t try to call a function within that Ask script. It apparently doesn’t have access to any of the function’s local variables that you’d probs need.

I’ve posted the updated game version, so time for the dev notes.

Version 1.4.2 Update

  • There are now 5 individual armor pieces, each with six sizes from XS to XXL
  • Each armor piece can be grown out of separately, complementing the dynamic WG system
  • Updated the trade system: Dynamic menu for purchases, bulk sale for identical items, selling ends when you leave the region
  • New cheat item for fast weight gain or weight loss. Access via cheat code.

Bugs squashed:

  • I have no idea where I left off after the site went down, but I probs fixed something

Current Bugs:

  • ???

To Do:

  • Harvest Monsters
  • Implement Round Boar
  • Implement Stats System
  • fbbbbjg uhhhh, Everything Else

#11

i think when you updated the armor or barter system it made items unequipable. specifically this error i got with the longsword: "Error running script: error compiling expression ‘p!ayer.attack+this.attack.’ Arithmeticelement: operation ‘Add’ is not defined for types ‘objects’ and ‘int32’


#12

So far this looks awesome, keep up the good work!

One thing though…
image
…Why not?


#13

We found the bugs already! Great!

Bugs Squashed:

  • Weapon attack attribute changed to atk to match player.atk
  • Fixed bug where equipping Long Sword would display as a Short Sword and end up permanently glued to the player’s hand.
  • Updated Complete_purchase function to call SetVerbs function, thereby removing the useless Equip verb and displaying the implemented Wear verb.

I posted the fixed version. Should be much better now. ^-^


#14

I found another bug in my opinion.
The Fairy Girl looks you over.
Error running script: Error compiling expression ‘Long Sword.equipped=true and player.armor=true’: CompareElement: Operation ‘Equal’ is not defined for types ‘Object’ and ‘Boolean’
I’m wearing all the S armor and have a potion yet this happens when i ask the fairy girl for the hidden passage.
I found another bug that happens with the fighting. After you fatten up the character you can’t fight anymore causing this text to appear.
Error running script: Error compiling expression ‘oponent.health - player.dmg2’: Unknown object or variable ‘oponent’
It’s a tall and fearsome bear with a big gut hanging down. It pants heavily and stands up on its hind legs to threaten you, before dropping down tiredly with a loud thump.
The {opponent:name} tries to use its speed advantage to get in the first hit, but you stumble out of the way.
What will you do?
It will happen every time you click fight doing 0 damage.


#15

Oops, looks like there’s more


image


#16

Are Burgers supposed to lower your max HP?


#17

Something that merits mentioning: If your armor is tight, it reduces your agility by 1. If it’s very tight, it reduces agility by 2 and max health by 1. Because.
There should be flavor text in there somewhere, but I think it only triggers when you fasten the armor. I should add in something turn-based to help people notice.

ps. Defense is always +3 for fastened armor and +1 for unfastened armor. Unfastened armor is looser. When you’re moving through tight spaces, the smaller dimension (you or your tight-ass armor) is referenced. Put on the tightest armor that will fit and maybe you can crawl into that cave.


#18

What’s this cheat code then? I’ve tried the numerical representation of thin to fat but it’s not recognising it?


#19

So i got to a point where the game wouldn’t let me fight anymore. Also, is there a way to squeeze into caves when you’ve gotten fat? I was wearing all fastened armour and it still wouldn’t let me.


#20

Gotta report this bug, I keep getting a gameover in the shop. It sometimes heppens when I leave talking to Mel.