Forest & Shack (Quest WGRPG)

video-game
weight-gain
fat

#42

Lol, so I’m not in the mood to test anything, but, supposedly, I made a lot of stuff work.

Version 1.5.0 Update

  • New Dismantling System
  • New Monsters: Round Boar, and Thick Snake
  • New Dunes Region (to the West)
  • New Items: Boar meat, tusks, and fur
  • New Items: Wolf meat, fangs, and fur
  • New Items: Bear meat, claws, and fur
  • New Items: Snake meat, venom, and skin
  • New Item: Carving Knife

Bugs Squashed:

  • Fairy Dialogue bug (post quest)
  • Armor Bonuses bug (permanent HP decrease)

Current Bugs:

  • Something that happens when you snap your armor off?

To Do:

  • I… Implement Stats System (author is intimidated)
  • More Monsters/Events in Dunes Region
  • Just Finish the Stats System Already!

#43

Great job on the 1.5.0 update! Didn’t expect so much so quickly.
I was wondering something while playing, however: Is it intended that you can no longer eat the dead bodies of the fauna? I find that this causes a slight issue, that you cannot obtain fat-increasing food after a certain size, since cheeseburgers are the sole way to gain weight. (besides the quest, but that’s a one-time thing) Maybe Mel can sell food?
I assume this is either you testing and learning how to implement a crafting system, and you did really well if that was what you intended.

And naturally, Bug Report:

  • The Snakes do not spawn corpses when killed, meaning materials are unobtainable (as an aside, shouldn’t the Thick Snakes be worth more than 14 exp? They have 120 Hp, and only give double the exp as the bears, which have 30 Hp. I don’t mean to tell you what to do with your game, this is just what I immediately thought when I killed my first snake).

  • This is hard to tell, but after testing a bit at various weight stages, the hidden Defence stat seems to be wonky, and all I can tell is that when fighting this Thick Snake, it is the hardest enemy in the main area. When I first encountered it I had four armour pieces on (all except the sleeves), and all of them were indeed fastened, so the defence should have been +10 according to the descriptions. I was Level 1. I was at the starting weight for my character, about 125lbs. The Thick Snake could damage me if it got a high enough roll, sometimes doing one or 2 damage to me, but usually doing 0. I fought two and ended with like 4 Hp. Later on, after doing the main quest and becoming in the fat stage, I got one level up, making me level 2. One of my armour pieces were unfastened (the corset) and I went back to the dunes to fight the snake. After repeated encounters, I noticed I never took any damage in these fights, which, to my knowledge, shouldn’t mathematically be possible. I tested further after taking a few potions and going to 120lbs, as well as unfastening all of my worn armour. I fought more snakes and still, never took any damage. I decided to test further, but after removing all the armour I had on. Still, never took a single point of damage. Dropped the armour pieces, same result (no damage). I got curious and fought all types of enemies, and I never took damage anymore, even though I was stick-thin and armourless. I’m sorry for the long report, but details are important in bugs, I believe. My theory is that somehow this Defence stat is not being reduced like it should when you remove/unfasten/outgrow the pieces of armour. Either that or when you level up, the defence stat increases a lot more than expected.

  • drop Bear Claws (2)
    Error running script: Error compiling expression ‘Bear Bones’: Unknown object or variable ‘Bear Bones’

  • drop Carving Knife
    Error running script: Error compiling expression ‘Carving_Knife’: Unknown object or variable ‘Carving_Knife’

  • drop Wolf Fangs
    Error running script: Error compiling expression ‘Wolf Bones’: Unknown object or variable ‘Wolf Bones’

  • drop Boar Tusks
    Error running script: Error compiling expression ‘Boar Bones’: Unknown object or variable ‘Boar Bones’

  • There is no button on the side menu to sell armour pieces, but you can input “sell (xyz)” and it will be sold to Mel. Not so much a bug as an observation, but I’ll put it here anyways.

UPDATE

  • I am now unable to pick up dead bodies? I don’t know what causes this, but this is the same playthrough with encountering all the bugs I found above. I reset the game, and could pick up the bodies again, not sure what causes this yet, still testing. I cannot pick up dead wolves now, all I did in the meantime was pass the Fairy’s check to open the hidden path, get three pieces of armour and equip/fasten them, and kill a Boar and encounter the bug just below this.
  • take dead Round Boar
    Error running script: Too few parameters passed to my_take function - only 1 passed, but 2 expected

  • Okay, about the pick up dead bodies bug, I think this occurs after examining or doing something with the according creature’s materials. For example, I kill and dismantle a Big Bear, and then look at Bear Fur. From now on, I cannot take Dead Big Bears, and when I do, the body disappears, even though the game still counts the dead Big Bears that I encounter. Curious, is all I can say. Just curious about this bug.
  • After killing the Bee and drinking from the spout, you get the Fairy City Portal Stone. Naturally, you’d want to go report this to the fairy, right? Well I didn’t do this, and continued testing stuff. Later when I decided to go see the Fairy City, I spoke to the Fairy and noticed that my dialogue options are the following:

speak to Pervy Fairy Girl
Talk to the Pervy Fairy Girl about…
1: I found your Portal Stone.
2: I found your Portal Stone.
3: I found your Portal Stone.
4: I found your Portal Stone.

So this happened because I went to the shack three times previous before I decided to speak to the fairy. I assume that in the code, it checks for Fairy City Portal Stone as well as Pervy Fairy Girl each time you enter the shack, and if both are true, then a dialogue option is added to when you speak to the Fairy. So each time I went to the shack, the checks came out true and as such added more and more of that option (I AM PROBABLY INCORRECT AS TO HOW THIS WORKS I’M JUST MAKING SENSE OF IT FOR MYSELF).

I highly appreciate how much you are working on this, and thank you for the patch notes too!


#44

Dev Notes 1.5.1

  • New Room: Junkyard (a room in the Fairy City where dropped items gather. However, items dropped in rooms with traders remain in that room. Fairy’s can’t snatch things when merchants are watching.)
  • Stats system. (D-did I really?! Yess!! No magic spells yet tho…)

Adjustments:

  • Adjusted Thick Snake’s Stats: Raised Atk and Exp, lowered Hp.

Bugs Squashed:

  • Thick Snakes now spawn corpses when killed: added monster to spawn_dead list.
  • Can now drop: Bear Claws, Wolf Fangs, Boar Tusks, and Carving Knife: replaced placeholder names with final names when calling the function.
  • Can now reliably pick up corpses: needed to pass the quantity to the take function call.
  • Pervy Fairy Girl repeating dialogue solved. (@AmyHuntr You guessed the reason completely right!)
  • Sell Button for Armor: overrode Quest’s _SetVerbsForGarment() function
  • Changed Honey Spout to call my modified UpdateGarment() function. Should’ve been the only thing left that could mess up the armor bonuses…

To Do:

  • More monsters/encounters for dunes region
  • Magic system

#45

How do I save the game to play offline?


#46

I believe you need to have the Quest software installed on your computer. When you do, you can download the game with the “Download file” button on the right column of this page
You can get the Quest software here:
http://textadventures.co.uk/quest
Currently it looks like you can only get it for Windows, I didn’t really look into it for Mac, since I don’t use a Mac.


#47

Once again, great work on the game.
But also, still gonna be more bugs:

  • When you get defeated by a basic enemy, the enemy doesn’t despawn from that area. So this causes an anomaly to occur when you return to that area, but a/an different/another enemy spawns there. In your surroundings, there is the enemy that spawned as well as the one that defeated you earlier, but the latter creature is just… there. It won’t do anything, since it isn’t in a battle state.

  • Removing/unfastening armour still doesn’t reduce the defence like it should. Hard to explain, but you can duplicate it like this:

  1. Buy any armour you like and equip/fasten it.
  2. Fight any enemy with the armour equipped. (should take less damage)
  3. Remove the armour you had equipped.
  4. Fight any enemy again without any armour equipped. (Still takes less damage)

Not too sure about this one, still testing scenarios.
I noticed that after 4-5 fights after step 4 I started getting damaged again by bears and boars, which makes this even more confusing to me, since it’s acting like my defence is gradually diminishing, rather than lowering immediately when I remove the armour. Honestly really confused about this.

  • Not sure if this is intended, but you can dual-wield shortsword-longsword together.

  • It feels like meat isn’t spawning at a reasonable rate, I can have 10 Carving knives and I rarely ever get meat from a corpse, but when I get a single one from a body, all of a sudden meat from that specific beast comes by the handful. It’s like it’s hard to get that first piece, but once you get one, they won’t stop coming.

  • Unable to give the Fairy City Portal Stone to the fairy now, seems that by removing that check, the option isn’t unlocked at all anymore. (Don’t know if this matters, but I teleported to the city before giving her the stone)

  • Cannot find a way to enter this Junkyard that was added. Perhaps it has to do with the Pervy Fairy?

Balance & quality of life concerns: (this is my opinion, don’t feel obliged to take anything I said as an order)

If the newly added taxidermy materials are going to be worth so much gold, (wolves are worth on average 10 gold now, and bears around 20) then gold is much easier to come by now. Don’t know if this is okay or not, but it’s just a simple observation I am noticing.

Alongside these materials, this causes a lot of different items to pile up in your space pouch. Selling to Mel when you have numerous amounts of various items can take upwards of 10+ commands. I’m not too sure how the code handles stacking items too well, but when you sell stacked items to Mel, it takes three commands to sell a single stack of an item (sell x, #, yes). I’m not too sure how to remove a step in this, since I am unsure of how stacked items work, but I feel like there is some way to shorten this process. A simple solution (at least for me, personally), would be to add numbers to the options of dialogue to Mel, similar to the options presented at the very beginning. This won’t solve the overall ‘issue’, but it would be like a band-aid until something else is thought of.

Ideas:

Maybe adding further weight stages to the dynamic? (Immobility?) Making Strength and Agility a stat now opens up possibilities much like noone’s fatty text adventure. Look at the player descriptions in that game if needed (or I can DM them, if offered) as inspiration or ideas for how to better describe fatness and strength for your character.

Body types. This can be pretty complicated, I think, but there probably is some sort of ratio to how weight is distributed through your character’s body. Could it be possible to reshape this somehow? This may cause issues with how armour fits and dilemmas with the character description, since, as far as I know, the descriptions are triggered when you break some sort of check having to do with weight/height/age/gender sort of thing, and doesn’t call on each of the body measurements to give you a description for each of them. (I’m realizing more and more how complex this is as I’m writing this, props to you Luna for coding all of this so well!)


#48

Please correct me if i’m missing something obvious, but after killing the bee soldier and getting the fairy city stone when I go back to the shack and talk to the Pervy Fairy Girl there are no conversations. what i mean by this is that there is no way to return the stone or talk to her in general after I am return from the hidden path. If someone could explain why this is happening or what I am missing it would be greatly appreciated, thank you.


#49

This is happening to me too, after reading through this page I think it is a bug caused by the fixing of another bug in the game. You aren’t missing anything obvious.


#50

Obviously, I’m taking a break from this at the moment. Life got busy, you know how it is. If there are problems in the game right now, sadly, they’ll just have to stay here.

Well, it’s not much and it’s full of bugs, but I’m glad so many people enjoyed it a little.


#51

I looooooove this game and I’m super happy to see there was an update since I last played! I know there are quite a few bugs, but as long as they’re eventually solved that’s 100% fine! I look forward to the next update!!! :smiley:


#52

Right, not sure if this question has already been asked, but when I click on the link it seems that I’m stuck with one of the older updates. I can kill the bee soldier and drink from the honey spout, but when I get to the fairy city, I can’t do anything and the only things that are there are the fairy city square and the fairy city skill hall, with nobody to talk to and nothing to interact with.