Turris Puesco?

I can’t remember where, but someone had gotten the game as a persona file on their computer. I would like to try that game out, but can’t figure out how. Some help would be appreciated!

1 Like

You need to install XAMPP, download the files from Github, and follow the instructions in this post. I’m a little confused at how I got it working, but it can work.


What even IS this game?

1 Like

It was an online text adventure WiP made by Cryptic once upon a time. I thought it was gone with the site tbh.

It didn’t have the online functionality yet, aside from character storage.

1 Like

Character storage? Like pokemon? XD

Nah, like your character was stored online. Originally you had to play always online, even though it was all single player. And yet I still wish it was still worked on.


I’m having a bit of trouble with all the files. A bit of a nightmare for me, haha

No- it was just how save data was handled.

I just wandered over to the GitHub and someone made commits as recently as December 2nd. I’m cautiously optimistic!

I followed the instructions in that thread and was able to make a character, but during the tutorial this error came up.

Looks like an error in the SQL syntax. It’s possible that the code written for the game is out of date with current versions of SQL, since the game code was written years ago. Might want to try an older version of SQL. Can’t help you much more than that though. I don’t have time to dig into all this again.

I really need some help with this. I genuinely have no idea what I’m doing with code or xampp. So far I have xampp downloaded, I’ve got the folder in the h folder, and I even (hopefully) made a database called dbwgrpg and tried to put the file from the folder in it, but I’ve gotten this message
– ------------------------------------------------------------ Table structure for table tblcharacteritemxr–DROP TABLE IF EXISTS tblcharacteritemxr
and currently if I try to play the game, there’s a lot of errors on it.

Was able to go through character creation, but this happened when Seraphine gave me armor
Fatal error : Uncaught PDOException: SQLSTATE[42S02]: Base table or view not found: 1146 Table ‘dbwgrpg.tblclothingdesc’ doesn’t exist in C:\xampp\htdocs\wgrpg\Database.php:20 Stack trace: #0 C:\xampp\htdocs\wgrpg\Database.php(20): PDO->query(‘SELECT strXML\n\t…’) #1 C:\xampp\htdocs\wgrpg\RPGItem.php(146): Database->query(‘SELECT strXML\n\t…’) #2 C:\xampp\htdocs\wgrpg\RPGItem.php(107): RPGItem->loadXMLName() #3 C:\xampp\htdocs\wgrpg\RPGItem.php(43): RPGItem->loadItemInfo(‘6’) #4 C:\xampp\htdocs\wgrpg\RPGCharacter.php(637): RPGItem->__construct(‘6’) #5 C:\xampp\htdocs\wgrpg\DialogConditionFactory.php(212): RPGCharacter->giveItemWithSetEnchants(‘6’, ‘M’, ‘1’, ‘2’, ‘1’) #6 C:\xampp\htdocs\wgrpg\command.php(40): DialogConditionFactory::evaluateAction(‘giveItemWithSet…’) #7 {main} thrown in C:\xampp\htdocs\wgrpg\Database.php on line 20

1 Like

Update: Messed around redownloading things, now I can successfully get the armor, but equipping it does this.

Warning : Trying to access array offset on value of type null in C:\xampp\htdocs\wgrpg\DataGameUI.php on line 80

Fatal error : Uncaught PDOException: SQLSTATE[42000]: Syntax error or access violation: 1064 You have an error in your SQL syntax; check the manual that corresponds to your MariaDB server version for the right syntax to use near ’ intStatusEffectID = ‘1’’ at line 3 in C:\xampp\htdocs\wgrpg\Database.php:20 Stack trace: #0 C:\xampp\htdocs\wgrpg\Database.php(20): PDO->query(‘UPDATE tblchara…’) #1 C:\xampp\htdocs\wgrpg\RPGStatusEffect.php(122): Database->query(‘UPDATE tblchara…’) #2 C:\xampp\htdocs\wgrpg\RPGCharacter.php(239): RPGStatusEffect->save(‘205’) #3 C:\xampp\htdocs\wgrpg\DataGameUI.php(284): RPGCharacter->save() #4 C:\xampp\htdocs\wgrpg\DataGameUI.php(15): DataGameUI->handleTicks() #5 C:\xampp\htdocs\wgrpg\DisplayGameUI.php(77): DataGameUI->__construct() #6 C:\xampp\htdocs\wgrpg\main.php(35): DisplayGameUI->__construct() #7 {main} thrown in C:\xampp\htdocs\wgrpg\Database.php on line 20

1 Like

I have the exact same issue, and i have no clue what to do.

1 Like

If I had to guess, on line 121 of RPGStatusEffect.php, change the comma on this line of the query to “AND”, like it is in the remove function right below.

That syntax probably worked in an older version of MySQL, but you guys likely downloaded the latest version with your xamp bundle (or latest version of MariaDB? I read it’s a fork of MySQL but don’t know if that would make any difference).

Honestly I have no clue what im doing with this stuff and I’m just trying to nod my head and follow directions

1 Like

Hopefully someone more skilled takes up revising some of the code and working out the bugs. Hell, if they were committed to creating more content, I’d be down to support them. Turris Puesco is just worth it.


I got if working by downloading an earlier version of XAMPP found here and following the same instructions from earlier in the thread, XAMPP - Browse /XAMPP Windows at SourceForge.net, I did the one from December 2019 but I don’t know the cutoff point is.