I just wish there was a simpler way to play the game, I haven’t touched it in years but I remember it being really good, that and I cant get it to run despite following the steps but im not very tech savvy sadly.

1 Like

Alright, I think I fixed the issues! This is my first time seeing PHP so it took me a bit. The bug was really subtle: (a != instead of a !==, gotta love it).

Anyway, I forked it with my changes here:

Installation instructions for both the previous method and the new Docker method are provided. I suggest the Docker method for most people, but that’s just me. Note if you follow the Docker instructions, the site is now at http://localhost:8401/wgrpg NOT http://localhost/wgrpg .

@eidde, if you’d like the changes merged over I can make a pull request on your repo.

Last, if you run into any bugs let me know. I haven’t played a ton, but it seems to work as a remember it!


Bad news, its asking for a linux update on my windows download when I try to load the docker so it instantly closes or asks for it to be reset to default settings, not sure what to do from here since I tried both redownloading and reseting to default lol

Are you on an up-to-date Windows 10 or above? There are some instructions here which may help:

I’m not super familiar with the process with the Windows installer, but the thing its complaining about it probably WSL/WSL2. You need it to install the program, though I had thought the installer would take care of that for you.

If you can open your command prompt, try putting in:
wsl --install

After that, if the installation still isn’t working, let me know what
wsl -l -v

If the Docker install isn’t working you can also always try the other method listed as (Manual).

Fantastic! This made a lot of the things work like a charm. I think the only issues I have now are the usual scripting glitches with the uhhh barkeep aaaaand… finishing the wizard quest currently. Something about trying to access array offsets in RPGFloor’s document.

/Starting/ the quests in the restaurant and with the knights are working like though. Even though it seems the Iyanna weight quest isn’t actually… happening? I can loop the VIP dialogue whenever. Lol. free food I guess!

1 Like

There also seem to be no changes to the fat descriptions of your body even when you’re at bloblike proportions. Was it always like that or can that be fixed as well?

That’s great to hear! As for the bugs:

  1. What is supposed to happen?
  2. What actually does?
  3. How do you get there?

If I have this I can look into them and try to fix it. (I’m not actually super familiar with the content of the game!)

Are you talking about when you look in the mirror? Looking through the files it appears the descriptions stop at BMI (or body part fatness) of 39.

I got it to work boss! Thank you so much. Would you work on this to add stuff to it ever by chance? Or just helping some of us out by making this fantastic piece playable again? Either way your awesome thanks a ton!

Yes but it feels like it stopping at less then 39 for me. Unless of course the 39 BMI descriptions is when it gets to a certain point before bloblike. A shame if so.

Another bug I ran into, I am not sure if it’s due to me not having used the stop command, but the game only saved some of my progress. Like my stats but not my levels, but my equipment was the same, but I lost a lot of the weight and floor progress up the tower. Also the restaurant started working too but I am not sure if it was due to me getting to floor 3 or not. My relationships with the quest givers are there, the magic and physical fighter class teachers, but the quests themselves are gone and I can’t reactivate them.

  1. I’m assuming there are supposed to be scripted dialogue events.
  2. I get these prompts! which I can ONLY assume means that files are missing/misplaced for the events and then causes this big old load chain reaction issue to occur. Similar to this for the Wizard/Norman has happened even before your patches but before I even got to START the caster quest-- Likewise with the barkeep. Both before and after attempting the Warrior Quest completion at the barkeep does the same thing.
    (library post caster completion)

    (dragon’s barrel barkeeper attempting to turn in warrior quest. Happens both prior obtaining the quest and after with no distinguishable differences.)
  3. I hope these screenshots and details helped answer this one. I’m happy to answer anything else! I’m also not familiar with the content so apologies ;w;

It happened again, is it because I am playing it on my private browser that it’s confused because it’s saving all of my cookies or something?

NGL I forgot about this. Glad to see it’s still playable in some capacity.

Glad you were able to containerize it, that’s something that was sorely needed that I never found the time to do. No need for a PR, I took care of merging it. I don’t currently have any plans for this, but it seems like there’s interest, so I may pick it back up. I’d love for it to become a community project that anybody can contribute to, and I’ll be around fairly regularly so I’m happy to “manage” a base repository if nobody else wants to.

@Batty It looks like there’s an error getting the event data from the database, and the XML filename is coming back blank, so instead of loading XML/EventData.xml, it’s trying to load XML/, which causes an error since that’s not a path to an XML file. From what I remember, those events are in the game, so I’m not sure what’s causing the issue now.

@Gluttonyan When you say you didn’t use the stop command, do you mean you left it running in between sessions of playing the game? If so, did you turn off your computer during that time?


The first time I closed out the tab WGRPG was in and didn’t use the stop command. The next time I did I used the stop command before refreshing the tab to see if it worked and it did but that also might have messed it up. I didn’t turn off my laptop right away unless you meant I should have turned off Docker as well after using the stop command.

I figured out the problem with the Norman and Iyanna stuff.

As you might know, the game seems to use a conversation level system to determine certain factors, and so some events in the game are registered in ‘tbleventconversation’. I’m not sure what this accomplishes; however, the DataGameUI is set to check this conversation level when displaying events if the event is registered in that table. One of these checks is to see if the player’s conversation level is “too high” for the current event. I assume this is supposed to be some sort of way to prevent the player from seeing conversations they leveled past.

The problem is that the if statement for if the player is too high a conversation level for an event is broken. Right now the condition uses var == null which gives an incorrect result that keeps basically anything that uses the conversation levels from working. changing any null comparisons to using is_null seems to fix it.

basically, change line 60 of DataGameUI.php to:

if(!is_null($objEvent->getConversationLevel()) && ((!is_null($_SESSION['objRelationship']->getConversationLevel()) && $objEvent->getConversationLevel() > $_SESSION['objRelationship']->getConversationLevel() + 1) || is_null($_SESSION['objRelationship']->getConversationLevel()))){

and that problem should be solved.

I made a fork today and fixed it on that. Will probably try to push it to the main git repo soon.

1 Like

How do you even run this? I downloaded the zip and there’s no .exe file or anything in the folder.

This game was originally made as a server-based game hosted on a website. As a result it can’t be run normally. There’s a readme on the github repo that tells you how to run the game.