Bug report thread!

bug

#1

This is my first coding project so naturally it’s a real mess. If you run into anything weird/buggy please, please let me know here. Provide as much detail as possible about what lead up to the event and screenshots if available.

a few known minor bugs and how to fix them:

  • BLACK SCREEN - screen go perma-dark? Use any of the teleporting maps and it should reset. Death will also reset you.

  • INVISIBLE - sprite turn invisible? Talk to any splash screen and exit, you should reset. Death fixes this also.

  • TOO-BIG TEXTBOX - find any other large textbox (the book in the hotel is a good one) and flip through it. The boxes should reset.

NOTE

I am no longer going to be updating the demo. Please keep this to the latest release bugs only!

Thank you~


#2

I found something just now-

After getting Henriette the BOB-3 GRO, and finding out the ‘expansive’ results of her ‘research’, I, of course, helped her out. The encounter resolved normally- I had my character take a large portion before milking the rest with the machine.
Then, after she asked me to step outside, I re-entered to find her in such a state again. The helpful sort that I am, I started the encounter again, but I got a message saying “I don’t think it’s time for that…”. Afterwards, all graphics disappeared except for the combat menu, and the encounter resolved normally from there.
All future attempts of that encounter so far have resulted in the same error.


#3

Very very odd…I’ll look into it. Thanks for all the detail~


#4

Found the issue, it was very simple too ^_^; For now unfortunately don’t use the key item in the secret Henriette event.


#5

I did come across an annoying bug where after being milked and heading toward town, I just get a black screen, can’t move at all, and I can access the menu…
though aside from that, I have no idea if thuis bug is brought about by hunger or the milking…


#6

There have been some weird bugs about hitting “hungry” just as you get into town or, being hungry when you enter the town.

But I’ve only really seen it loop dialog, not just go full black. I’ll look into it.


#7

Found a couple.

One, fairly simple, the giant cow quest, the current text says “you need a strength of 45 exactly” I believe that’s supposed to be 15? because you can finish that quest at WC 15?

Two, and this one’s a bit weirder, but as I was coming back after finishing that quest, I was JUST at the transition from outside the city to inside the gates when I got the notification that my stomach was rumbling, and I needed to eat something soon. I clicked through the message, got back into the city, and got stuck in a loop of constantly being told my stomach was rumbling.
It looks like you’ve put out a patch since I last downloaded, so it’s possible one or both of these have been fixed. Thank you SO much for making this game 8D It looks AMAZING so far 8D and I’m really enjoying it ^.^


#8

Oh yeah, the cow issue was my fault ^_^; originally the idea was to be weight class “15” before you could complete the event but I changed it to “Strength” as there’s a few items and events that can up the players strength and I figured putting the check on that, to reward the adventurous spirit, would make for more interesting gameplay.

However…dummy me forgot to actually change the check to look for “Strength” and not level despite changing the text ^_^;;; I can’t remember if that got fixed in the latest patch but I think it was???

and ah yes…that is a very known bug. I’m working on fixing it. It’s amazing how often people simultaneously enter the town just as they hit hunger. That’s what’s causing the bug and despite the odds it’s somehow very prevalent.


Super Fatty RPG: Full Version!!!
#9

I’d recommend adding some kind of case regarding when it goes to call the notification about hunger just before it does anything else, “If location = in town then end function” or something like that. Don’t know how you’ve got all that set up, so maybe this isn’t feasible? Just… whatever’s causing it to NOT go to the next step, figure out a way to make it go to the next step.

Good luck 8D and again, loving the game ^.^


#10

That’s not a bad idea…very obvious in retrospect. I ended up fixing it in a different way but if that fails on me I may just do this.


#11

Loops are really annoying/tricky, but also pretty simple. If you get stuck in one, Why are you trapped? enter a case you missed, so you’ll pop out of the loop. Better version is to figure out why you started the loop in the first place, and add a case there to prevent starting it at all, but that can be harder.

Worst case, I had a programming teacher once who recommended adding a counter to everywhere and anywhere you could possibly end up back at the start. If that counter hit some arbitrary number, say five, then end function. Add in an error message and give it a different name/number that displays before ending the function, and you can even get feedback about what caused a given counter to trigger, what case did you miss when setting up your if/then statements. (Again, this relies in part on your code being set up in a way that this works for. If you’re looping in a place you shouldn’t be ABLE to loop… that’s harder XP)


#12

Gonna post up a bug I just found here.

When fighting ??? I went into the fight JUST as I got hungry, and the hunger debuff persisted through the whole fight which made it pretty much unwinnable.


#13

The “spontaneous hunger” problem strikes again. But this one is easy, I know how to fix~


#14

10
Yo, I can clip into this green jelly thing just fine. It’s like it’s not part of the background!


#15

Thank you! And thanks for the screenshot! I’m actually already aware of this one and have fixed it for later versions~


#16

Also the guy at the ‘bridge’ won’t let me pass, not even after I’ve reached Level 10 weight class. Is it a bug or am I missing something?


#17

I should have made a comment there tbh but you can’t go across at all in the demo. That’s for a later release.


#18

Its the other building with the awning over the door (on the right of your screenshot) that leads out of town.


#19

Hello. Just wanted to say first that I’m really enjoying the game thus far and eagerly looking forward to your future progress. Wanted to start with that because of that old saying about how people are more likely to complain than offer a compliment, so I like to try to give praise where it’s due. Really don’t have any complaints, but somehow just dropping a message on your project the first time with only a bug report didn’t feel right.

Anyway, I’m not even 100% sure if it was a bug or if it was intentional. I’ve noticed that, in fights with any of the slime monsters, if the Slime X-Tractor deals a killing blow then no slime is received. So it seems like the code is set up to perform a certain amount of damage, check if the slime is defeated, and then determine how much slime the player receives based on the damage. I’ve become familiar with coding and that’s just a very high level observation and assumption on my part. I could be mistaken, of course.

As an example, if I’m combating the Bloo-Berry Slime and it has 40 health remaining and I use the Slime X-Tractor, I will always collect Blueberry Jams depending on the damage I do (i.e., 1 for 10 damage, 2 for 20, and 3 for 30). However, if the Slime has only 30 health remaining then I get one of two results. If I deal 10 or 20 damage then I get the one or two Blueberry Jams, respectively. If I deal 30 damage with the X-Tractor, though, then the Slime simply dies and no Jams are collected. Again, not sure if this was intentional or if it could just be the order in which everything is checked and, if so, if it’s just a matter of moving the check for collecting slime to before it checks if the monster is defeated.

(Just as an aside, for some reason I kept wanting to write “Blueberry James” rather than “Jams.” Now I can only wonder as to who the heck Blueberry James is. Maybe he sings the Blues…)


#20

Thank you very much!!!

And while you’re not too far from the mark the amount of slime jars you get is actually randomly generated (1-3) but it does do damage first and the game stops processing everything the minute the enemy dies (an RPG maker default that’s been a real problem tbh).

Long story short this was an oversight on my end. I should flip collecting the slime and damage so it doesnt really die until you actually have the slime.