Bug report thread!

bug

#21

Ah, those odd little engine limits. Don’t get me wrong; I think engines are great. You get to avoid a lot of the infrastructure work that can make projects drag, but they all have their quirks. In any case, sounds like you have a good solution. I’m going to have to pay closer attention to the slime encounters. I easily could’ve just imagined the correlation.

Speaking of slime, I ran across an unrelated item. I’m offering it more as a “heads up” than as a “bug report.” I really can’t claim it’s a bug if I broke something on purpose and went places not yet prepared. I managed to dig up the “Vore (Large)” ability. Mostly, it was curiosity. (Partly, it was wanting to see if it existed to get some sense of vindication after a bad ogre encounter… Sort of…)

Anyway, the ability seems to work fine overall (take that, jerk ogre), but it seems it does not work specifically with the various slime monsters. For the Lemon, it actually comes back with the message
“You may be biting off more than you can chew…” For the Apple and Bloo-Berry, that message does not appear. It is almost as though it does not seem to actually execute the function at the end after running through the messages of grabbing them, etc. For all other encounters, though, it appears to work just fine. (I’m assuming you’re not ever meant to be able to actually eat the lost cows… Don’t judge me! I was irked by the sassy one! …Okay, go ahead and judge…)

Again, just wanted to offer it as a heads up item. I understand that isn’t even supposed to be accessible yet. I can only expect that something will not work correctly if I’m breaking the rules.


#22

To be honest this one is easy. No vore abilities past medium were truely completed in the demo ^-^;;;; nor were enemies really set up to respond to them right. since there’s no way to get to it naturally I just didn’t bother fixing larger vore moves and instead spent my time on more relevant things.

However, at this point I’ve already scrapped all that and started it over with a new system for vore for the full release that I believe is much cleaner anyways. To be honest the way I did it for the demo was very clunky and more limiting than I wanted it to be.


#23

Another possible ‘bug’ , but when fighting the burger monster the attack message mentions…Slime??

22


#24

Oh shoot I thought I fixed that. This one isn’t a technical bug, I just posted the wrong dialog to the wrong enemy. ^-^;


#25

Found one recently after “fully completing” the demo, after getting all 6 tokens in it. Was at WC 35 when I went to the field with all the fattening food in the farmlands. Decided to eat everything there, because giant fatties are in my interests. It cuts to the black screen with the dialogue of me gorging and growing endlessly, then it shows the dialogue of going beyond your WC and ending up back at the hotel. THEN it plays the dialogue of you unable to get out of the field, while in the hotel, and then the massive belch and cut to black screen.

And it just stays in the black screen. Can open the menu, tried using the Gater Park map, and still black screen. Went north, talked to Gnate and said goodbye, still black screen. Seems the game is still playable, just completely blind…


#26

Very bizzare…I’ve gotten quite a few reports of the “perma black screen” after going through the fat field…I’ve done what I can about it so I hope it’s resolved by next update.

If you are ever permanently blinded, unfortunately the only solution is to find a way to die. Several events run when you respawn that sort of “reset” the game and it should clear up the blindness.


#27

Hmm. I’ll have to keep that in mind. I just return to the title screen and reload the game. Although going back to the fat field at WC 34 plays it normally. I guess, in my opinion, it only does the perma black screen if you go there on your max WC.


#28

Enjoying the game demo a lot so far and can’t wait for the Halloween release.

That being said, I did come across a bug early on in the city. After using some digest-aids to the point where I was hungry, it was constantly looping the message that plays when you reach a low fullness level and wouldn’t let me continue the game until I closed it.

Another bug I found in Gater-Park with Big Gnate. After the Delivery Quest to Tsuchinoko, Big Gnate still acts like you’re accepting the quest for the first time. I’m guessing some post-quest dialogue would pop up saying “thanks” or commenting on Tsuchi if one selects “Delivery” again


#29

Thank you!!! Luckily I’ve already fixed these issues UwU (though the Gnate thing was simply that I forgot to write the dialog, and not a technical bug whoops)


#30

I’ve noticed quite a few bugs with the Halloween update, I’ll put the ones I found in an orderly list.

-The poles on the awning outside the hotel and gate to the outside of the city are missing.

-Choosing to go “Full Time” at the farm eventually drained all milk and made it impossible to gain any new milk, it also made the BOB-3 GRO pills unable to be used and removed the peach icon. (May have been caused by entering and exiting the city.)

-The watermelon and melon icons are visible on your status when inside the city, the watermelon icon persists outside the city while the melon does not. (May have caused the above issue.)

-The number are off, fullness, health, strength, charisma, etc. are all way higher than they were in the last test build. The weight class gain when turning in a phone token is also higher, giving an increase of 8 maximum weight classes as opposed to the 5 during the test build and as stated in game. (Not completely game breaking but makes the game very easy. The heightened strength does not allow you to move the enormous cow needed for the phone token earlier though, I still needed to get to a higher weight class to move them.

Those are the ones I’ve found, hope it helps.


#31

The final battle doesn’t actually give a token after it’s over. There’s dialogue wherein your character has the token tossed to them, but it doesn’t actually show up in your inventory after the encounter.
This happened on multiple retries, where I went back and did the fight a few times with nearly the same result every time.
Only difference was at one point I finished the fight with the boss dead but one of the supplementary enemies still alive, which resulted in the fight immediately restarting once combat left (the boss dialogue just started over from the beginning, tossing me straight back into the fight I just beat).
Not sure if it had anything to do with it, but I was around weight class 90 and a werewolf at the time of the fight (though I did the fight transformed and not-transformed; same result either way).
Hope this helps.


#33

I’m going to fix the icon and look into the full-time thing but, I really can’t find any issues on that. Is it possible for you to go into more detail about what happened that “drained all milk”

Also, I should have mentioned this here, the change in stats is totally intentional. The game has gone through a massive re-balancing overhaul. And the poles have been removed due to some odd collision issues later when you get bigger.


#34

I did legitimately forgot to add the token WHOOPS ^_^; I did a quick update this morning to fix that and a problem with the fruit icons, feel free to re-download.

Though I also realize you can fight the final boss indefinably, this was not intentional but, unless anyone has any real issues with it I may go ahead and leave it be.


#35

Sorry, I realize how poorly I put it. It was like the amount of milk was set to 0 and wouldn’t go up again, I wouldn’t have even known if it wasn’t for the model changing. I really don’t know what could’ve caused it since I know very little of game programming, my best guess is some sort of overflow caused the milk amount to be set to a nil value.


#36

I’ll have to look into it. But how did you know it got set to zero? Did nothing respond to it?


#37

No, I tried walking around for a few minutes but it did nothing, I didn’t know what else to try after that, the milker didn’t work, BOB-3 GRO pills didn’t work, I did everything milk related I knew I could do, I was stumped to say the least.


Super Fatty RPG: Full Version!!!
#38

I’ll just have to look into it when I get home later then. Thank you~


#39

Found two spelling and grammar errors. Bob’s sentence cuts off at ‘…choose “part-time” or "full-time’ and there is no ending quotation mark or period. Also, in the Status screen where it says your max weight class does not have an ending period either.

Also if you’re a cow you can sometimes not have the status condition that makes you produce milk even while you’re still a cow. Is this intended?

Another problem I found was in the Polly Pecker event where it says “A fresh slides in front of you…” where I assume it it is supposed to say a fresh pie. Second one is with “Rogers concern is starting to make you feel guilty…” I assume this is supposed to say “Roger’s” in the sentence?

For some reason the Cultist submit event fades to a black screen three times and twice on the same scene of the morbidly obese you. Why does it fade into the same scene twice?


#41

i may have a sound problem… is the game suposed to have music in the city? because i have none :frowning:Currently the rest seems fine.


#42

There’s no music in the game unfortunately. It just wasn’t something I could get to.