Bug report thread!

bug

#63

Yeah the boogie fight in general has a number of isses I hope to resolve and update soon. Everything you mentioned is on the list rest assured.

But the boogie fight is the final token, it just keeps giving you tokens for some reason lol.


#64

Oh shoot did I not mention, you CANNOT transfer save data from the demo to the new version. There’s too much that won’t work.


#65

so I got the Gum gun and I can no longer talk to the boss after trying to get that loan dealt with… not sure if that’s the cause, but I think I’m hard locked or something


#66

Okay, so I don’t know if anyone’s reported this, I didn’t skim as throughly, but I DID figure out the hard lock, turning in all of the tokens before paying the wg loan and going to the office locks the office and disables the phone


#67

I’m about to fix that right now. I’ll have a new update up in just a second. Sorry I thought I got that one ^_^;;;


#68

s’all good, just want to help as much as I can


#69

Okay, I think I found a weird one.

Untitled

So what happens here is that I snuck in the back door of the do-nut shop, it was ajar, and I went in. And then it says the clerk sighs at my plea for mercy? And it just tosses me back out again.

My guess is that it’s playing the submit option when fighting the clerk. I will say, I’ve only fought the clerk once in a previous playthrough, and I didn’t submit to him, so I don’t know how that plays out. But it seems that the glitch is that it’s playing it here instead of letting me eat donuts? It plays as soon as I sneak in.

Untitled

Continuing leads to this.

Edit: I figured it out! The delivery boi submit glitch is still active! After submitting to this guy, I auto-submit to the next fight. I submitted to the delivery boi again, and then went into the shop from the backdoor, and it played the scene again, submitting to the clerk and being let go before I could eat any donuts.


#70

Hey, it’s me again. When you go into a battle with more than one enemy and you have the Bubble Gun to fatten your target, it softlocks if you use it again on the bloated enemy.


#71

Oh shoot. You’re right about the delivery boy submit problem though, and I thought I fixed that ^_^;


#72

I found this out myself too. I’m not sure what’s really causing it at this time but I’m looking into it.


#73

Not exactly a bug just something that’s kind of frustrating. At the end of the demo, if you pay off the full 100,000 interest on the loan, the boss leaves. The fact they can leave was mentioned on the thread with the download, but not that paying is the trigger for it is. But I hadn’t done most of the side quests he offers, so a bunch of content just poofed, and it takes a pretty good chunk of time to grind back up to the endgame if I want to go back and get that content. Is there a variable or something in the save file that can be used to un-do that? This website https://www.saveeditonline.com/ can edit save file, but it only gives numbers for the variable names and I don’t particularly want to go full guess and check. If there’s an easy way to undo that in my save file, it would be appreciated!

Edit: One of the values was -110000, and seeing as that was the total amount paid I tried reducing that but it didn’t work. I’m guessing one of the others values is a quest stage flag controlling it, but I don’t know which.


#75

The switch to change is switch 80. But I really, really would like more detail on exactly the events that lead up to this.


#76

Paying the loan is not the trigger, giving 12 tokens is…I’m really not sure how you managed to trigger this @_@ He only leaves if you give him 12 tokens. Literally nothing about the loan is tied to the boss leaving. Did you somehow get 12 without finishing the additional quests??? Did some of them give you extra???


#77

Hey! As far as I know none of them gave me extra, but I don’t have perfect recollection. I definitely didn’t start messing with save files or anything until after it happened. I only have 11 token receipts, and can say with certainty that when I paid off the 100,000 was when the phone went to buzzing and the building locked up.

Here’s my save file when it happened, I made a backup copy when I started tinkering with it. It’s a 7z file so the forum will let me upload it.
backupSave.7z (10.3 KB)


#78

Also, the way this file is viewed by the online save editor, none of them are labled as ‘switch 80’. Can you tell me what the value is after the phone locks up? That way I can pick out which one it is and try to bump it down one.


#79

Sorry, I don’t know how the program you’re using designates the switches…It’s switch 90 labeled “ALLTOKEN”. That’s all I can say.

Also, sorry I said the wrong number it was 11 receipts. So if you have 11 receipts you’ve done everything in the game? What side quests did you not get to complete? You can check the walkthrough to see if you were missing anything but that’s all there is to get unless you got way more tokens than you were supposed to.

I’m really not sure how the loan could have set off the dialog though. I’ve never heard this one before so, maybe it’s just lag.


#80

I hadn’t done the final boss/cultist quest or the food delivery quest from the Boss, but I had done the quest with the Ace of Spades. I put a link to the online save editor I’m using - it’s all in browser.

After posting the bug, I went back and talked to the guy on the beach, got the passcode, fought big elvis, and he dropped me a token, but I have no way to cash it in since the Boss is already gone (and I’m at max 100 already anyway).

Switch 80 or switch 90 doesn’t help. Can I assume that it’s (current) value is 11 then, and that that’s the switch the game is checking whenever I try to use the phone or go in the building? So if I set it to 10, maybe I’ll be able to get back in.

It does appear that I picked up an extra token somewhere along the way, but I have no idea where.


#81

There was a few extra token problems here and there I tried to squash. I also tried to make it so the boss wouldn’t leave without you completing the boogie quest in earlier updates (if you haven’t updated since 11/4 I would do so, but it wouldn’t undo this current issue)

If anything, know that you’re not really missing anything. The reward for the disco token was just him leaving and the food delivery quest wasn’t a legit quest it just got you some splash dialog.


#82

Um… I think I found a major bug.

Summary

When I payed of the innitial debt I never actually got an office map, thus locking me out of part of the game.


#83

I’m afraid I don’t understand how you got locked? Are you not able to go get the map?