Bug report thread!

bug

#105

I can confirm that the same thing happens to me.


#106

Sorry about the late reply!
I went back and tried again, going in and out of the casino about a hundred times, and every single time Heriette was in Bradley’s room when I came back. I wonder if it’s not clearing the state of the room properly, because the number of times I enter and leave the room before Hetiette shows up seems to vary between three and five.


#107

So, I don’t know if anyone has had this problem in the past but after bringing the bat to the casino every time I attempt to enter the casino after that point my game crashes with a crash box poping up that reads: " Script ‘Game_Map’ line 41: ArgumentError occurred. dump format error for symbol(ox21)
Any help?


#108

This games seems incredibly buggy and unplayable. When I’ve eaten food and I haven’t maxed it out it’ll reset my weight class and put me back at the hotel after telling me I can’t move anymore. The game is literally unplayable because I can’t progress past WC 4.

Another bug that happens is when I get down to ZERO hunger the message repeatedly pops up that I’m hungry and should eat something soon and won’t go away. It gets stuck in a perpetual loop with the message keep popping up after dismissing it, rendering the game completely unplayable and unable to progress the game.


#109

I’ve never seen or heard of these issues before. Have you tried redownloading the game?


#110

This is super duper late cuz I haven’t been keeping up: but please do at least a little research before declaring a game “unplayable”. I don’t expect you to have to read the entire forum but even a brief skim of this thread should tell you that not only have people progressed past this point, but even beaten the game entirely.

To be honest I have no idea how the errors you’re experiencing are happening. The minimum level for the immobility dialog is six.

I suggest re-downloading and following the provided walkthrough to make sure you aren’t just missing something.

And please, for real, try to be a little more courteous. SFRPG is a small, buggy and incomplete project so it doesn’t matter as much here, but blasting out “game is buggy and unplayable!!!” Without any effort on your part to assure it’s not some kind of user error can be damaging to indie game projects and developers.

Sorry if this comes off harsh. I saw it at a bad time. But I stand by what I say.


#111

Your arrogance as a developer is astounding, so don’t always expect your game to work for everyone, like the case what issues I’ve had with the game. So you cannot dismiss what issues that I’m having right here as nothing. As a developer you should be listening to feedback and criticism where its due, if you can’t handle those then you shouldn’t be a developer.

I do understand this is only a small project that you did to learn programming, but please be reasonable when someone reports an issue with the game they are having, otherwise they will never support you or your game projects.

The looping issue as I mentioned is game breaking and unplayable, meaning you have to start over with a new game because the dialogue kept popping up over and over again even though I read through it. I’d be happy to record a video of the issues I got with the game just to prove it. The issues I have are reproducible, so it’s not me having “no effort” as you may call it.


#112

Ok I’m stepping in here before things get to crazy. While you are correct a developer should listen to feedback and criticism, you could handle giving your criticism with more tact and more constructively. These are games that are made in the developers free time without pay and are released for free for all to enjoy, and at minimum they deserve respect for their endeavor.

Was @Impossiblesnail’s response a bit harsh, possibly, but at the same time you cant declare that

In the general case when it can be seen that most people have only been experiencing minor issues and that @Impossiblesnail has been very good at dealing with any game breaking bugs that where found.

To be clear while I found your original post a bit disrespectful it’s your response to @Impossiblesnail that is out of line. Keep the insults out of it and try to include more useful details on how to reproduce the bugs you encounter so the developers can track them down easier, and if you want to provide any criticism do better than broken and unplayable.

Consider this a warning.


#113

That’s odd, I didn’t encounter either of those bugs my whole playthrough. Do you have any odd settings on your computer that might be interfering with anything?


#114

Excuse me, but where have I been disrespectful or thrown insults? There weren’t any and my original post was fair in feedback and criticism.

Was @Impossiblesnail’s response a bit harsh, possibly, but at the same time you cant declare that

The answer is not “possibly” it was definitely, but not justified in the tone that was given. Yeah so what it’s a free game done in someone’s free time, that doesn’t give it a free pass when criticism and feedback are presented. And lastly do not threaten me with warnings, you are totally out of line, just as much as @Impossiblesnail’s post was too.

So I highly suggest you be very careful with your wordings.


#115

I mean, you did call a game that other people have had no problem with unplayable as a whole without giving any info besides “it’s buggy and doesn’t work” and then called the dev arrogant. Also lol at trying to tell an admin they can’t give out warnings.


#116

In my book that’s an insult. Now I will be clear here, you WILL comply with our request and watch your behavior or we will take administrative action against you for violating our community guidelines and failing to comply with an admins requests.

Final warning.


#117

Hello,

I have not been able to recreate these problems myself in the early game. Assuming you havent been able to leave the city yet. I would recommend redownloading the game and keeping note of the steps you take in case an error occurs again. (I.e. if you do anything strange in the burger battle or when talking on the phone)

At this stage of the game theres a lot of code done by a one man team so any extra information is always helpful to help them locate the issue internally. Otherwise we have to assume it might be a hardware issue on the player side. Hopefully the issue is resolved with the redownload and you can continue deep into this hedonistic game, but if not just make sure to type up an unbiased account on any steps taken to where the error occurred. That goes to everyone still playing the game who come across any bugs that were missed. Thank you all for playing Snails game!


#118

Your original post was not fair; you described the game as “unplayable”. I think anyone would understand that that means you think the game cannot be played. Even a cursory look at the forum for this game would show that this is not even remotely true; many have played the game and enjoyed it. Is it possible to get past WC4 - yes it is many have as evidenced by the comments about how to solve the puzzles for much higher WC. The criticism is therefore inacurate, unfair and unhelpful. It is disrespectful to over-egg your complaint (and it does read as a complaint - rather than a bug report) in this way.

I can totally understand @Impossiblesnail’s reaction - in fact I thought it was quite tame considering.

Is there a problem where an underfed character can repeatedly die and re-spawn? Possibly. That’s one for @Impossiblesnail to look at. But of course why would he bother investing more of his time into the project if he’s just going to get replies like yours?

Take care when posting, don’t deprive the rest of us of games to play.


#119

This is just a general announcement, while the sentiment is appreciated please do not respond directly to @Alkaris post in this topic.

We understand there is an urge to respond to their comments, but please allow us to handle it and only use this topic for reporting bugs.

Thank you all for your understanding.


#120

Love the game!

Just one small problem, and I have no idea what’s causing it, but
Whenever I enter the Casino’s Restaurant, after a few seconds the game crashes with the error

Unable to find file:
Graphics/Characters/SLIME

I have the Cow TF and the Slime TF, and I have also gotten the Gum Gun, I have also finished the game and wanted to see the max WC size, hence why I was going to the restaurant.

Any fix for it? I’ve tried reinstalling to no avail.


#121

This one I really have no solution for. Nor no idea why it’s doing it. The game is trying to look for the slime sprite sheet that I’ve removed becuase I never finished it.

But…I deleted everything in the game that should be looking for it??? and this error seems exclusive to the casino??? and there’s nothing about a location that should affect player sprites like that???

Anyways. I do apologize. This is just another on a long list of unsolvable problems. Save before going into the casino.


#122

Alright, that’s fine, to clarify it’s just the restaurant that crashes me, and even then not right away, but at any rate, kind of borks my save then considering I saved just after the Penthouse side mission in the lobby, but ah well, that’s life, and there’s other ways of getting to the max size.

Thanks for at least trying to help though.


#123

Same problem, found this thread just now. I don’t know much about coding, so forgive me if this is a dumb idea, but what if you just gave the game a spritesheet to find? You don’t have to actually make a new spritesheet for the slime, you could probably get away with copying the default one over or something as long as it has the same name as what it’s trying to look for.

My guess is it’ll either “fix” the bug, or it’ll lead to some other error and give you some insight as to what’s going on.


#124

EDIT: nevermind apparently it was that easy and I was barking up the wrong tree on this problem.

You’re on the right track…but the problem is a bit sticker than that.

A lot of what goes wrong with the game is the result of my convoluted work-arounds with the system. Its a needless mess of nonsense that, now that I understand code more, was more broken than even the problems I was trying to solve.

Its one of the biggest reasons I can’t really continue to work on it…its just too broken ^-^; (that and time, but Ive already mentioned that)

Anyways, all this to say that you do have the right idea. And that is basically what I need to do. But the game shouldnt even be looking for those sprites at that time…and thats the real problem.