Fetish Master Legacy Edition (v03 2021-12-23) w/ Maternal Reads Fetish Master

Right, so there are two versions of Fetish Master in this context. They are the Fetish Master Legacy Edition here and the Fetish Master tweaked by Maternal-Reads here.

Both are effectively different versions of Fetish Master. What I have done is, put Maternal-Reads Fetish Master into the Legacy Edition of Fetish Master. I did this because the Legacy version runs on a newer Java and I can’t seem to find older Java versions on Oracle’s website anymore.

I also found the Maternal-Reads version of FM added a bunch of stuff mainly lying in the “gamedata” folder. Also the numerous text documents it adds as well. So all I had to do in order to make the Legacy edition of FM run Maternal-Reads content was just take the Maternal-Reads FM “gamedata” folder and drop it into the legacy edition. When I ran it, the Legacy Edition ran just fine.

So, that’s mainly it. Of course, the content Maternal-Reads added, and Juxtaterrestrial’s belly mod, which is in it as well, are all theirs and the person who wrote the legacy edition of FM is still theirs as well. I am taking no credit for either of them. Just credit for mashing them together. The download for this version can be found here.

My patch that fixes a few things on the Maternal-Reads FM will still be needed. If the user wants these issues fixed. Otherwise, carry on.


Just to be clear because maternal reads never credited me anywhere, half the content in her mod is my content from an out of date version of my belly mod. A lot of the stuff that isn’t theirs was built on top of my content.

Not sending any animosity your way, i just wanted to put that info out there.


I had no clue. All right then.

will this actually run on most recent systems? I tied to re-download FM and it needed a java drive to run on windows 10 and nothing found by google would work

Yes. I ran it on Linux and Windows 11 with some of the latest hardware.

Glad to see some support for jimbobvii’s version of the game. I played for a bit and didn’t run into any issues so it is nice to be able to play this on a more modern version of Java.

I’ve always wanted to but never had the patience to make a compatibility patch for some of the larger mods such as Maternal Reads’ mod, Juxt’s mod, Nostradamus’s mod, etc and bring them to jim’s version of the game so it is nice to see that it works somewhat.

yea was able to get it working, so it seems that the one I had was missing the actual java game file to actually play the game

Also @Lupusvir1 is this just maternal read’s content or does it include other mods for FM? I know there was some unfinished weight gain mod that no one wanted to continue or replace due to how much there was of it

Just Maternal-Reads content. Some of the other mods I found did not work well with it.

Praying for the day where the majority of all the different FM mod content works together. Theoretically is this able to be used as a mod base or would it be easier to use a more vanilla version?

1 Like

Easier to use more vanilla. Mainly because maternal-reads alter how some of the core things are done. Which throws the other mods out of whack.

In fact, one such alteration is character descriptions. They added more information to it and how it’s displayed. They also added more variables to the character and organs themselves to add some other details.

For a mod base, it’s better to use the Fetish Master Legacy edition. As the older engine might not run on a newer system. Also, any older mod should theoretically work on the re-coded engine. Mainly because of how it’s literally just the engine redone on a more modern Java. How the core game works is unchanged.


Not sure from what version this came from but Ruby lipstick is bugged.
Line 8 in lipstick.item file is missing “+” sign. Fixed line in question below:

"Opening it up and trailing the stick around " + consumer.HisHer() + " " + IncludeRange(consumer.getStat("lips.size"), "lipssize") + " lips, their lips become a deep and glossy shade of red.";

All right then. Thanks for locating it. I’ll update the line.

Update: I couldn’t find the issue. I went to the salon, and the lipstick application worked just fine.

It is not the lipstick from salon, it is the one you get form the city.