The Last Cresani(formerly Lanna's Adventures)

Alright everyone, after not working on it for year’s, I’ve got the next update for this out. The now renamed, The Last Cresani! I doubt it’s everything people well be expecting after being in devolopment for so long. This isn’t the full update I WANTED to put out, but I wanted to get something out there after so long. This has been bug tested by me and some friends, so I hope everything work’s out alright.

Thing’s that have changed:

-The entire beginning section of the game has been redone. I really didn’t like how the game started before.
-The Save function has been removed from the Menu, and an NPC will be used for saving. This is an attempt to help warn player’s when a boss is upcoming(hoping the locations for the NPC are all fine)
-Regular enemies and side bosses no longer give EXP. Only Gold. EXP has been changed to only be given by main story bosses. It’s easier to keep everything at a steady pace/flow when you have direct control over the player’s level.
-Side bosses do reward you with “Tomes”, which will teach the party new skills, provided you find someone who can read them.
-All side quests are now functional(far as I can tell), and there are more quests rewards for completing them.
-Some more armor and weapons added to the game
-Some of(not all) the older sprites have been redone.
-More side content added
-Bad End Viewer added

**How far does this update go, story wise?:**The story only include’s 3 of the 4 Shrine’s you need to visit, for this update.

And that’s it. Hopefully some people enjoy it, even though it won’t be perfect.

Special thanks to:

-Grimimic, Emett, Morionite, and my bug testers for the help they provided me.

-Added a message when starting a new game, to inform the player of when the update ends.
-Raised Spawn rate of Green Gills in the Water Shrine
-Fixed a bug in the Adventurer Guild’s arena
-Fixed a teleportion issue with a side cave, where a room couldn’t be entered.
-While not a bug, at the request of some people, I’ve adjusted one of the puzzles in the Water Shrine.
-Fixed a bug with the Bad End Viewer showing ending’s before it should.
-Fixed an issue where Scarlet and Silvianna would stay in the party for the farm side quest.
-Fixed an issue where the Loaner would still have text show up, even when he wasn’t there.
-Fixed scenes in the Bad End Viewer not playing back properlty
-While not a bug, reduced the hitboxes on the Harpies in the Wind Shrine.
-Fixed another issue with the bad end viewer.


Thank you, I really liked your previous update, I’m sure I would like this one :smiley:

Thank you very much. I really like the story in this game and a lot of cute fattie sprites, but I was wondering if there will be any fattening and belly growth on main characters? I am plaing for 3 hours already and still waiting for some magick, potions or food which can feed main characters and make them bigger. I found one NPC who sold me a boobs growth pill, but it looks like this is just a quest item. So, may I ask if there will be any main character body growth later?
Edit: Oh, nevermind. I just reached the end of latest update. Looks like all this awesome fatty sprites in game files are not implemented yet :slight_smile:

1 Like

I’m glad you like it lol

I’m not sure if there’s going to be a system like in Stuffing RPG, were you can make the girl’s big in game. A lot of my weight gain is done in cutscenes. And the party member’s have had several moment’s of it(mostly in bad ends, form losing to bosses)

Two glitches:

  1. I couldn’t fail the bee quiz even by getting every question wrong

  2. After the Queen tells me to go talk to Rylie, if I go south (I just realized I could go north), the scene repeats but without some of the sprites, and the game hangs in limbo.

Hmm, the Quiz one I swear i fixed. I looked at it several times. And I wasn’t aware of the repeating cutscene. Thank you much for pointing it out lol

So far, things have been working at least pretty well for me. A few things to note in terms of glitches:

  1. Going from the starting point back towards the first house after getting Scarlet on your team takes you back to the house as if you had just beaten Casandra(?)
  2. When leaving the queen’s room after getting to the end of the demo, the very middle tile used to trigger the cutscene beforehand is still active. Hitting it a second time at this point will softlock the game.
  3. You’re able to go to the farm after getting Scarlet, which breaks the game a bit, since Scarlet isn’t meant to be there.

Other than that, just the general spellcheck is needed. If there’s any more I run into, I’ll be sure to post them here.

How can I see the farm event? I don’t know how.

Am I the only one who found the Pink Slimes to be unreasonably tough for how soon the player encounters them? Sure, they’re a good source of money and EXP, but I personally found them to be more of a hassle than they were worth, even with a supposedly overleveled four-member party. If anything, they made me feel grateful for the Kill Spray item.

I found a couple of bugs during the scene in the castle tower. During the conversation, the sprite for the priestess woman (I forget her name) was layered on top of my party members when it should have been the other way around. After the conversation was finished and I tried to exit the throne room, the game triggered the previous scene with the queen a second time, except the cutscene bugged and forced me to reload my save.

In the Guild of Heroes and Villains, I joined the villain side and went to talk to the girl in pink. Unfortunately, I talked to her from the square north of her. When she tried to walk to the arena, she was unable to walk around me, getting me stuck in that scene. After reloading, I made sure to talk to her from the side, which fixed the issue.

When I went to check up on Carmen after Scarlet suggested it, entering and exiting the starting “room” to the south caused Carmen to despawn and be replaced with her house and Scarlet standing next to it. Carmen came back after I exited and re-entered through the east passage.

I also found a couple of bugs associated with the Breast Gems. First, I was able to buy the original one using the 200 gold I had on me, despite the asking price of 1000 gold. After giving it to the woman in the village, talking to her again triggered the scene for a second gem, which I didn’t have. I went and found the rest of the gems, but when I came back she was already in a state of having received all of the gems.

One last thing, and I’m sorry for such a long post. Where are all of the magic hay bales (yes, “bales” is the correct spelling in this context) to give to Scary? I can only find two of them. Does a new one spawn each time I give one to her? Are there only two in the game at this time?

I thought I fixed that first one. I shall have to look at it again. I knew about that second one(it’s been brought to my attention a few times now). And I knew about the Scarlet thing, though I didn’t put a “fix” in for it yet, because I wanted to get an update put up here before the thread got archived again. Thank you for letting me know though, the more bugs I know about the better.

There’s a guy in the Barrille Tavern you have to speak to first, then return to the farm.

Thank’s for the imput. Always good to hear what need’s fixed.

The Pink Slime’s are probably a little strong. I had a more leveled up party when I was testing t hem, so that’s my fault. They shall get nerfed.

The Guild bug is one I honestly forgot about, so thank you for bringing it to my attention again. That whole Guild might be blocked off, since I plan on redoing it anyway.

I’ve been made aware of that bug with “Cassandra’s” house. I thought I fixed it some time ago, but appearntly not. I s hall have to look at it again.

And the Breast Gem side quest gave me a bit of grief. Before I went on my month long vacation, i thought I had fixed it. But turns out I did not lol. I’ll likely have to redo the whole thing to get it to work properly.

As for Scary the ScareCrow, yes. There’s only two Hay Bale’s in the game. As of now. More well be added in the next update.

I dunno what I did wrong, but I was able to fail the quiz the last time I tried. SHRUG!!

Was unable to play the game after downloading it. At this point, I am unable to tell if it was because the download was corrupted, an error in the game, or something wrong with my Wine program.

Hey Kibz, I’ve been enjoying the old versions for a long time now. Not sure if this is on my end or not, but your mediafire link keeps sending me to download repair.

I can’t seem to download this game i’m a tad stuck on the mediafire download key

Hmmm, that’s weird. This is really a reply to the past few posts. I’m not really sure why it’s doing that. Has anyone ever experienced this before?

I’m getting the same issue. Mediafire says its generating a key. The continue button becomes clickable. I click it and it starts regenerating a key. And it just keeps repeating.

same but i thought it because you delete by mistake or mediafire being a dick… -.-

SO i found the questr for the magic hay bails and the scarecrow. Is that complete or am I just looking for nothing?